您的位置:首页 > 产品设计 > UI/UE

HDU 3177 Crixalis's Equipment (贪心+差排)

2014-12-07 21:12 441 查看

Crixalis's Equipment

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2904 Accepted Submission(s): 875
[align=left]Problem Description[/align]
Crixalis - Sand King used to be a giant scorpion(蝎子) in the deserts of Kalimdor. Though he's a guardian of Lich King now, he keeps the living habit of a scorpion like living underground and digging holes.

Someday Crixalis decides to move to another nice place and build a new house for himself (Actually it's just a new hole). As he collected a lot of equipment, he needs to dig a hole beside his new house to store them. This hole has a volume of V units, and Crixalis
has N equipment, each of them needs Ai units of space. When dragging his equipment into the hole, Crixalis finds that he needs more space to ensure everything is placed well. Actually, the ith equipment needs Bi units of space during the moving. More precisely
Crixalis can not move equipment into the hole unless there are Bi units of space left. After it moved in, the volume of the hole will decrease by Ai. Crixalis wonders if he can move all his equipment into the new hole and he turns to you for help.

[align=left]Input[/align]
The first line contains an integer T, indicating the number of test cases. Then follows T cases, each one contains N + 1 lines. The first line contains 2 integers: V, volume of a hole and N, number of equipment respectively. The next
N lines contain N pairs of integers: Ai and Bi.

0<T<= 10, 0<V<10000, 0<N<1000, 0 <Ai< V, Ai <= Bi < 1000.

[align=left]Output[/align]
For each case output "Yes" if Crixalis can move all his equipment into the new hole or else output "No".

[align=left]Sample Input[/align]

2

20 3
10 20
3 10
1 7

10 2
1 10
2 11


[align=left]Sample Output[/align]

Yes
No


此题以A排序 WA 以B排序WA Ai+Bi>A2i+B2还是WA!

#include<stdio.h>
#include<vector>
#include<algorithm>
using namespace std;
struct S{
int a, b;
};
bool cmp(const S &s1, const S &s2){
if(s1.a + s2.b == s2.a + s1.b)
return s1.b < s2.b;
return s1.a + s2.b < s2.a + s1.b;
//return s1.b - s1.a > s2.b - s2.a;	也可
}
int main(){
S s;
vector<S> vec;
int t, v, n, flag;
scanf("%d", &t);
while(t--){
flag = 0;
scanf("%d%d", &v, &n);
while(n--){
scanf("%d%d", &s.a, &s.b);
vec.push_back(s);
}
sort(vec.begin(), vec.end(), cmp);
for(vector<S>::iterator it = vec.begin(); it != vec.end(); ++it){
if(v >= (*it).b && v >= (*it).a){
v -= (*it).a;
}else{
flag = 1;
break;
}
}
if(flag)
printf("No\n");
else
printf("Yes\n");
vec.clear();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: