您的位置:首页 > 其它

HDU5078 2014 ACM-ICPC亚洲区域赛鞍山赛区现场赛I题 Osu! 签到题

2014-10-27 16:39 483 查看



Osu!

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 262144/262144 K (Java/Others)

Total Submission(s): 392 Accepted Submission(s): 230

Special Judge

Problem Description

Osu! is a very popular music game. Basically, it is a game about clicking. Some points will appear on the screen at some time, and you have to click them at a correct time.



Now, you want to write an algorithm to estimate how diffecult a game is.

To simplify the things, in a game consisting of N points, point i will occur at time ti at place (xi, yi), and you should click it exactly at ti at (xi, yi). That means you should move your cursor
from point i to point i+1. This movement is called a jump, and the difficulty of a jump is just the distance between point i and point i+1 divided by the time between ti and ti+1. And the difficulty of a game is simply the difficulty
of the most difficult jump in the game.

Now, given a description of a game, please calculate its difficulty.

Input

The first line contains an integer T (T ≤ 10), denoting the number of the test cases.

For each test case, the first line contains an integer N (2 ≤ N ≤ 1000) denoting the number of the points in the game. Then N lines follow, the i-th line consisting of 3 space-separated integers, ti(0 ≤ ti < ti+1 ≤ 106),
xi, and yi (0 ≤ xi, yi ≤ 106) as mentioned above.

Output

For each test case, output the answer in one line.

Your answer will be considered correct if and only if its absolute or relative error is less than 1e-9.

Sample Input

2
5
2 1 9
3 7 2
5 9 0
6 6 3
7 6 0
10
11 35 67
23 2 29
29 58 22
30 67 69
36 56 93
62 42 11
67 73 29
68 19 21
72 37 84
82 24 98


Sample Output

9.2195444573
54.5893762558

HintIn memory of the best osu! player ever Cookiezi.


鞍山区域赛的签到题,题目意思也很裸,就是给你n组数,表示每次到达某个位置的坐标和时间,求所有从i点到i+1点的最快转移,直接很简单的微小模拟,计算出每对相邻点之间转移的速度(两点间距离距离/相隔时间),什么都不用考虑直接做,当时在现场一直有传闻要添加水题,其实就是这道,但是我们现场赛的时候一直认为添加题目肯定不会和WJMZBMR有关(毕竟WJMZBMR赛前说过已经准备好100口棺材嘛),看到Osu时的确也因为这个原因跳过此题,但是看到3min时北航拿到FB时才开始做,倒是很顺利的1A拿下此题~~具体AC代码如下:

#include<cstdio>
#include<iostream>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<algorithm>
#include<map>
#include<vector>
#include<queue>
using namespace std;
struct st
{
double t,x,y;
}p[1005];
double cal(st a,st b)
{
return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}
int main()
{
//   freopen("in.txt","r",stdin);
int t;
cin>>t;
while(t--)
{
int n;
cin>>n;
for(int i=0;i<n;i++)
cin>>p[i].t>>p[i].x>>p[i].y;
double maxx=0;
for(int i=1;i<n;i++)
{
double item=cal(p[i],p[i-1]);
item=item/(p[i].t-p[i-1].t);
if(item>maxx)
maxx=item;
}
printf("%.10f\n",maxx);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐