您的位置:首页 > 其它

ZOJ3819 ACM-ICPC 2014 亚洲区域赛牡丹江赛区现场赛A题 Average Score 签到题

2014-10-13 16:06 423 查看
Average Score

Time Limit: 2 Seconds Memory Limit: 131072 KB

Bob is a freshman in Marjar University. He is clever and diligent. However, he is not good at math, especially in Mathematical Analysis.
After a mid-term exam, Bob was anxious about his grade. He went to the professor asking about the result of the exam. The professor said:

"Too bad! You made me so disappointed."

"Hummm... I am giving lessons to two classes. If you were in the other class, the average scores of both classes will increase."

Now, you are given the scores of all students in the two classes, except for the Bob's. Please calculate the possible range of Bob's score. All scores shall be integers within [0, 100].

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:
The first line contains two integers N (2 <= N <= 50) and M (1 <= M <= 50) indicating the number of students in Bob's class and the number
of students in the other class respectively.
The next line contains N - 1 integers A1, A2, .., AN-1 representing the scores of other students in Bob's
class.
The last line contains M integers B1, B2, .., BM representing the scores of students in the other class.

Output

For each test case, output two integers representing the minimal possible score and the maximal possible score of Bob.
It is guaranteed that the solution always exists.

Sample Input

2
4 3
5 5 5
4 4 3
6 5
5 5 4 5 3
1 3 2 2 1

Sample Output

4 4
2 4


这个题是牡丹江赛区的签到题,证明来过~~~其实就是很水的题目,题目告诉你你平均分高于第二个班,低于第一个班,让你求出分数上下区间,直接得到平均分数然后不管精度寻找还是暴力寻找都可以,反正总分最高才是5000分,怎么找都不会TLE,方法就随意了,是很水的题目,就不多说,具体AC程序如下:

#include<cstdio>
#include<iostream>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<algorithm>
#include<map>
#include<vector>
#include<queue>
using namespace std;
int main()
{
//   freopen("in.txt","r",stdin);
int t;
cin>>t;
while(t--)
{
int n,m;
scanf("%d%d",&n,&m);
int sum1=0,sum2=0;
for(int i=0;i<n-1;i++)
{
int it;
scanf("%d",&it);
sum1+=it;
}
for(int i=0;i<m;i++)
{
int it;
scanf("%d",&it);
sum2+=it;
}
int ti=1;
while(ti*m<=sum2)
ti++;
int l=ti;
while(ti*(n-1)<sum1)
ti++;
int r=ti-1;
printf("%d %d\n",l,r);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐