您的位置:首页 > 其它

sdut 3-4 计算长方形的周长和面积

2014-10-09 10:07 267 查看

3-4 计算长方形的周长和面积

Time Limit: 1000MS Memory limit: 65536K

题目描述

通过本题的练习可以掌握拷贝构造函数的定义和使用方法;
设计一个长方形类Rect,计算长方形的周长与面积。类中有私有数据成员Length(长)、Width(宽),由具有缺省参数值的构造函数对其初始化,函数原型为:Rect(double Length=0, double Width=0); 再为其定义拷贝构造函数,形参为对象的常引用,函数原型为:Rect(const Rect &); 编写主函数,创建Rect对象r1初始化为长、宽数据,利用r1初始化另一个Rect对象r2,分别输出对象的长和宽、周长和面积。

要求: 创建对象 Rect r1(3.0,2.0),r2(r1);

输入

输入两个实数,中间用一个空格间隔;代表长方形的长和宽

输出

共有6行;

分别输出r1的长和宽;r1的周长;r1的面积;r2的长和宽;r2的周长;r2的面积;注意单词与单词之间用一个空格间隔

示例输入

56 32


示例输出

the length and width of r1 is:56,32
the perimeter of r1 is:176
the area of r1 is:1792
the length and width of r2 is:56,32
the perimeter of r2 is:176
the area of r2 is:1792


提示

输入-7.0 -8.0

输出

the length and width of r1 is:0,0

the perimeter of r1 is:0

the area of r1 is:0

the length and width of r2 is:0,0

the perimeter of r2 is:0

the area of r2 is:0

来源

黄晶晶

示例程序

#include <iostream>

using namespace std;

class Rect
{
private:
double l;
double w;

public:
Rect (double x=0,double y=0);
Rect (const Rect &a);

const void display1()
{
cout<<"the length and width of r1 is:"<<l<<","<<w<<endl;
cout<<"the perimeter of r1 is:"<<(l+w)*2<<endl;
cout<<"the area of r1 is:"<<l*w<<endl;
}

const void display2()
{
cout<<"the length and width of r2 is:"<<l<<","<<w<<endl;
cout<<"the perimeter of r2 is:"<<(l+w)*2<<endl;
cout<<"the area of r2 is:"<<l*w<<endl;
}
};

Rect::Rect(double x,double y)
{
l=x;
w=y;
}

Rect::Rect(const Rect & a)
{
l=a.l;
w=a.w;
}

int main()
{
double x,y;
cin>>x>>y;
if(x<0|| y<0)
{
x=0;
y=0;
}
Rect rect(x,y);
Rect rect_copy=rect;

rect.display1();
rect_copy.display2();
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: