您的位置:首页 > 编程语言 > Java开发

java_sdut_计算长方形的周长和面积(类和对象)

2017-03-31 20:09 351 查看


计算长方形的周长和面积(类和对象)

Time Limit: 1000MS Memory Limit: 65536KB

Submit Statistic


Problem Description

设计一个长方形类Rect,计算长方形的周长与面积。
成员变量:整型、私有的数据成员length(长)、width(宽);
构造方法如下:
(1)Rect(int length) —— 1个整数表示正方形的边长
(2)Rect(int length, int width)——2个整数分别表示长方形长和宽
成员方法:包含求面积和周长。(可适当添加其他方法)
要求:编写主函数,对Rect类进行测试,输出每个长方形的长、宽、周长和面积。


Input

 输入多组数据;
一行中若有1个整数,表示正方形的边长;
一行中若有2个整数(中间用空格间隔),表示长方形的长度、宽度。
若输入数据中有负数,则不表示任何图形,长、宽均为0。


Output

 每行测试数据对应一行输出,格式为:(数据之间有1个空格)
长度 宽度 周长 面积


Example Input

1
2 3
4 5
2
-2
-2 -3



Example Output

import java.util.Scanner;

public class Main {

public static void main(String[] args) {

Scanner in = new Scanner(System.in);
while( in.hasNext() ){
Rect re;
String str = in.nextLine();
String []s = str.split(" ");
int cnt = s.length;
if( cnt==1 ){
int len = Integer.parseInt(s[0]);
re = new Rect(len);
}
else{
int len = Integer.parseInt(s[0]);
int wid = Integer.parseInt(s[1]);
re = new Rect ( len, wid );
}
System.out.println( re.toStr() );
}
in.close();
}
}

class Rect {

private int length, width;

public Rect( int len, int wid ){
if( len<0 )
len = 0;
if( wid<0 )
wid = 0;
this.length = len;
this.width = wid;
}

public Rect( int len ){
this (len, len);
}

public int getLen(){
return length;
}

public int getWid(){
return width;
}

public int area(){
return length * width;
}

public int circu (){
return 2*(length+width);
}

public String toStr(){
String res = length +" "+width+" "+circu()+" "+area();
return res;
}

}


1 1 4 1
2 3 10 6
4 5 18 20
2 2 8 4
0 0 0 0
0 0 0 0
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: