您的位置:首页 > 编程语言 > C语言/C++

SDUT-2673 3-4 计算长方形的周长和面积

2017-10-20 18:17 525 查看


3-4 计算长方形的周长和面积

Time Limit: 1000MS Memory Limit: 65536KB

Submit Statistic


Problem Description

通过本题的练习可以掌握拷贝构造函数的定义和使用方法;
设计一个长方形类Rect,计算长方形的周长与面积。类中有私有数据成员Length(长)、Width(宽),由具有缺省参数值的构造函数对其初始化,函数原型为:Rect(double Length=0, double Width=0); 再为其定义拷贝构造函数,形参为对象的常引用,函数原型为:Rect(const Rect &); 编写主函数,创建Rect对象r1初始化为长、宽数据,利用r1初始化另一个Rect对象r2,分别输出对象的长和宽、周长和面积。
 
 
要求: 创建对象 Rect r1(3.0,2.0),r2(r1);


Input

输入两个实数,中间用一个空格间隔;代表长方形的长和宽


Output

共有6行 ;

分别输出r1的长和宽; r1的周长; r1的面积;r2的长和宽; r2的周长; r2的面积;注意单词与单词之间用一个空格间隔


Example Input

56 32



Example Output

the length and width of r1 is:56,32
the perimeter of r1 is:176
the area of r1 is:1792
the length and width of r2 is:56,32
the perimeter of r2 is:176
the area of r2 is:1792



Hint

 
输入 -7.0 -8.0
输出
the length and width of r1 is:0,0
the perimeter of r1 is:0
the area of r1 is:0
the length and width of r2 is:0,0
the perimeter of r2 is:0
the area of r2 is:0


Author

 黄晶晶

构造函数:声明类时,数据成员不可初始化

若类的所有数据成员是公有的,定义对象时可以初始化



实现直接在类中定义构造函数







#include<iostream>
#include<algorithm>
#include<string>

using namespace std;

class Rect
{
private:
double l, w;
public:
Rect(double ll,double ww):l(ll),w(ww){}  ///注意冒号
Rect(const Rect &r)
{
l=r.l;
w=r.w;
}
void show1()
{
cout<<"the length and width of r1 is:"<<l<<","<<w<<endl;
cout<<"the perimeter of r1 is:"<<2*(l+w)<<endl;
cout<<"the area of r1 is:"<<l*w<<endl;
}
void show2()
{
cout<<"the length and width of r2 is:"<<l<<","<<w<<endl;
cout<<"the perimeter of r2 is:"<<2*(l+w)<<endl;
cout<<"the area of r2 is:"<<l*w<<endl;
}
};

int main()
{
ios::sync_with_stdio(false);//使用后加快cin和cout的速度,但将不能混用cin,scanf
double a, b;
cin>>a>>b;
if(a<=0||b<=0)
{
a=0;
b=0;
}
Rect r1(a, b);
r1.show1();
Rect r2(r1);
r2.show2();
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息