您的位置:首页 > 其它

1003. Emergency (25)——PAT (Advanced Level) Practise

2014-09-23 17:12 453 查看
题目信息:


1003. Emergency (25)

时间限制

400 ms

内存限制

32000 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked
on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (<= 500) - the number of cities (and the cities are numbered from 0 to N-1), M - the number of roads, C1 and C2 - the cities that you are currently in
and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected
by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.

Output

For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather.

All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input
5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output
2 4


代码如下:

#include <stdio.h>
#define MAX 0x7fffffff
int map[500][500];
int team_num[500];
int city_num;
int dis[500];
int meet_team[500];
char visit[500];
int npath[500];
int extern_min()
{
int min = MAX;
int result = -1;
for (int i = 0; i < city_num; i++)
{
if (!visit[i] && dis[i] < min)
{
result = i;
min = dis[i];
}
}
return result;
}
void dijkstra(int s, int e)
{
for (int i = 0; i < city_num; i++)
dis[i] = MAX;

dis[s] = 0;
npath[s] = 1;
meet_team[s] = team_num[s];
while (1)
{
s = extern_min();
if (-1 == s || s == e)
{
return;
}
else
{
visit[s] = 1;
for (int j = 0; j < city_num; j++)
{
if (visit[j] || map[s][j] == 0)
continue;
if (dis[j] > dis[s] + map[s][j])
{
dis[j] = dis[s] + map[s][j];
npath[j] = npath[s];
meet_team[j] = meet_team[s] + team_num[j];
}
else if (dis[j] == dis[s] + map[s][j])
{
npath[j] += npath[s];
if (meet_team[j] < meet_team[s] + team_num[j])
meet_team[j] = meet_team[s] + team_num[j];
}
}
}
}
}
int main()
{
int iroad, s, e;
int i, k, j, m;
scanf("%d%d%d%d", &city_num, &iroad, &s, &e);
for (i = 0; i < city_num; i++)
scanf("%d", &team_num[i]);
for (k = 0; k < city_num; k++)
{
for (j = 0; j < city_num; j++)
map[k][j] = 0;
}
for (i = 0; i < iroad; i++)
{
scanf("%d%d%d", &k, &j, &m);
map[k][j] = map[j][k] = m;
}
dijkstra(s, e);
printf("%d %d\n", npath[e], meet_team[e]);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: