您的位置:首页 > 其它

POJ 3181 - Dollar Dayz(完全背包+高精度)

2014-09-04 21:31 337 查看
Description
Farmer John goes to Dollar Days at The Cow Store and discovers an unlimited number of tools on sale. During his first visit, the tools are selling variously for $1, $2, and $3. Farmer John has exactly $5 to spend. He can buy 5
tools at $1 each or 1 tool at $3 and an additional 1 tool at $2. Of course, there are other combinations for a total of 5 different ways FJ can spend all his money on tools. Here they are:

1 @ US$3 + 1 @ US$2

1 @ US$3 + 2 @ US$1

1 @ US$2 + 3 @ US$1

2 @ US$2 + 1 @ US$1

5 @ US$1

Write a program than will compute the number of ways FJ can spend N dollars (1 <= N <= 1000) at The Cow Store for tools on sale with a cost of $1..$K (1 <= K <= 100).
Input
A single line with two space-separated integers: N and K.
Output
A single line with a single integer that is the number of unique ways FJ can spend his money.
Sample Input
5 3

Sample Output
5


                                                   

题意:给出总钱数 n 和钱币种类 k 种 ,钱币数量不限,求出能组成钱数的方案数。

思路:完全背包,前面的方案数应该与后面的方案数叠加,所以状态转移方程是 dp[j]+=dp[j-i];

           小数据测试正确之后交上去WA了,在测试 1000 100这组数据的时候爆了,使用高精度的思想,定义两个 long long 的数组,一个记录高位,一个记录低位。

CODE:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <string>
#include <cstring>
#include <queue>
#include <stack>
#include <vector>
#include <set>
#include <map>
const int inf=0xfffffff;
typedef long long ll;
using namespace std;

ll dp1[1005],dp2[1005];
int main()
{
int n,k;
ll mod=1;
for(int i=1;i<=18;i++) mod*=10;
while(~scanf("%d %d",&n,&k)){
memset(dp1,0,sizeof(dp1));
memset(dp2,0,sizeof(dp2));
dp2[0]=1;
int ans=0;
for(int i=1;i<=k;i++){
for(int j=i;j<=n;j++){
if(dp2[j-i]){
dp1[j]+=(dp1[j-i]+(dp2[j-i]+dp2[j])/mod);
dp2[j]=(dp2[j-i]+dp2[j])%mod;
}
}
}
if(dp1
)printf("%I64d",dp1
);
printf("%I64d\n",dp2
);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  DP POJ