您的位置:首页 > 其它

hdu 1081 To The Max(最大子矩阵)

2014-08-12 09:13 344 查看
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1081

[align=left]Problem Description[/align]
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle.
In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.

As an example, the maximal sub-rectangle of the array:

0 -2 -7 0

9 2 -6 2

-4 1 -4 1

-1 8 0 -2

is in the lower left corner:

9 2

-4 1

-1 8

and has a sum of 15.

 

[align=left]Input[/align]
The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace
(spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will
be in the range [-127,127].

 

[align=left]Output[/align]
Output the sum of the maximal sub-rectangle.

 

[align=left]Sample Input[/align]

4
0 -2 -7 0 9 2 -6 2
-4 1 -4 1 -1
8 0 -2

 

[align=left]Sample Output[/align]

15

题意就是给你一个n*n的矩阵,求最大子矩阵的和。。

首先我们会求一维的最大连续和,dp[i]表示以i结尾的最大连续和,那么有

if(dp[i]>0)

dp[i+1]=dp[i]+a[i];

else

dp[i+1]=a[i];

那么最大的和res就是dp[i]中的最大值了。。

我们把这个二维的转换为一维的即可,我们枚举枚举行,直接给出核心代码

for(int i=1;i<=n;i++)

        {

            memset(b,0,sizeof(b));

            for(int j=i;j<=n;j++)

                {

                    int sum=0;

                    for(int k=1;k<=n;k++)    //求出从i行到j行的每一列的和

                        b[k]+=a[j][k];

                    for(int l=1;l<=n;l++)     //一维的求解方法

                    {

                        if(sum>0)

                           sum+=b[l];

                        else

                           sum=b[l];

                        if(sum>max)

                            max=sum;

                    }

                }

        }

我们用b数组求出从i行到j行的每一列的和,这样我们就得到一个一维的序列,然后用一维的算法即可。。

完整的代码:

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#include<string>
#include<math.h>
#include<stdlib.h>
#include<map>
#include<queue>
#define max(x,y)x>y?x:y
#define min(x,y)x<y?x:y
using namespace std;
const int maxn=110;
int a[maxn][maxn],b[maxn];
int main()
{
//freopen("in.txt","r",stdin);
int n;
while(scanf("%d",&n)==1)
{
for(int i=1;i<=n;i++)
for(int j=1;j<=n;j++)
scanf("%d",&a[i][j]);
int max=-999999999;
for(int i=1;i<=n;i++)
{
memset(b,0,sizeof(b));
for(int j=i;j<=n;j++)
{
int sum=0;
for(int k=1;k<=n;k++)
b[k]+=a[j][k];
for(int l=1;l<=n;l++)
{
if(sum>0)
sum+=b[l];
else
sum=b[l];
if(sum>max)
max=sum;
}
}
}
printf("%d\n",max);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: