您的位置:首页 > 其它

hdu 1081 To The Max(最大子矩阵)

2015-11-18 00:50 543 查看


To The Max

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 10238    Accepted Submission(s): 4928


Problem Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the
sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.

As an example, the maximal sub-rectangle of the array:

0 -2 -7 0

9 2 -6 2

-4 1 -4 1

-1 8 0 -2

is in the lower left corner:

9 2

-4 1

-1 8

and has a sum of 15.

 

Input

The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines).
These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

 

Output

Output the sum of the maximal sub-rectangle.

 

Sample Input

4
0 -2 -7 0 9 2 -6 2
-4 1 -4 1 -1
8 0 -2

 

Sample Output

15

 

Source

Greater New York 2001

 

#include<cstring>
#include<cstdio>
#include<iostream>
#define N 111
#define INF 1e8

using namespace std;

int sum

;
int n;

int main() {
//freopen("test.in","r",stdin);
while(~scanf("%d",&n)) {
memset(sum,0,sizeof sum);
for(int i=1; i<=n; i++)
for(int j=1; j<=n; j++) {
int x;
scanf("%d",&x);
sum[i][j]=sum[i][j-1]+x;
}
int ans=-INF;
for(int l=1; l<=n; l++) {
for(int r=l; r<=n; r++) {
int all=0;
for(int i=1; i<=n; i++) {
all+=sum[i][r]-sum[i][l-1];
ans=max(ans,all);
if(all<0)all=0;
}
}
}
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息