您的位置:首页 > 大数据 > 人工智能

UVA 10494-If We Were a Child Again(大数类)

2014-08-08 17:45 405 查看
Problem C

If We Were a Child Again
Input: standard input

Output: standard output
Time Limit: 7 seconds


“Oooooooooooooooh!

If I could do the easy mathematics like my school days!!

I can guarantee, that I’d not make any mistake this time!!”

Says a smart university student!!

But his teacher even smarter – “Ok! I’d assign you such projects in your software lab. Don’t be so sad.”

“Really!!” - the students feels happy. And he feels so happy that he cannot see the smile in his teacher’s face.






The Problem



The first project for the poor student was to make a calculator that can just perform the basic arithmetic operations.



But like many other university students he doesn’t like to do any project by himself. He just wants to collect programs from here and there. As you are a friend of him, he asks you to write the program. But, you are also intelligent
enough to tackle this kind of people. You agreed to write only the (integer) division and mod (% in C/C++) operations for him.

Input

Input is a sequence of lines. Each line will contain an input number. One or more spaces. A sign (division or mod). Again spaces. And another input number. Both the input numbers are non-negative integer. The first one may be arbitrarily
long. The second number n will be in the range (0 < n < 231).


[b]Output[/b]
A line for each input, each containing an integer. See the sample input and output. Output should not contain any extra space.



[b]Sample Input[/b]
110 / 100

99 % 10

2147483647 / 2147483647

2147483646 % 2147483647

[b]Sample Output[/b]
1

9

1

2147483646

第一次用java写,以前从来没看过,今天看了一点基本的输入输出切了一道A+B后,直接来一道高精度的,1A

,没有编译器,直接敲完就交,谁给我的勇气?。。。待会写一篇总结java里面的高精度大数的用法

import java.io.*;

import java.util.*;

import java.math.*;
import java.text.*;
public class Main {

		public static void main(String args[]) {

		       Scanner in = new Scanner(System.in);

                       BigInteger a,b;char c;
                       while(in.hasNext()){
		       a = in.nextBigInteger();

                       c=in.next().charAt(0);
		       b = in.nextBigInteger();

		       if(c=='/')
                       System.out.println(a.divide(b));
                       else
                        System.out.println(a.mod(b));
                       
                      }
		
               }

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: