您的位置:首页 > 其它

hdu 4496 D-City (并查集)

2014-08-07 21:28 323 查看


D-City

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65535/65535 K (Java/Others)

Total Submission(s): 1439 Accepted Submission(s): 537



Problem Description

Luxer is a really bad guy. He destroys everything he met.

One day Luxer went to D-city. D-city has N D-points and M D-lines. Each D-line connects exactly two D-points. Luxer will destroy all the D-lines. The mayor of D-city wants to know how many connected blocks of D-city left after Luxer destroying the first K D-lines
in the input.

Two points are in the same connected blocks if and only if they connect to each other directly or indirectly.

Input

First line of the input contains two integers N and M.

Then following M lines each containing 2 space-separated integers u and v, which denotes an D-line.

Constraints:

0 < N <= 10000

0 < M <= 100000

0 <= u, v < N.

Output

Output M lines, the ith line is the answer after deleting the first i edges in the input.

Sample Input

5 10
0 1
1 2
1 3
1 4
0 2
2 3
0 4
0 3
3 4
2 4


Sample Output

1
1
1
2
2
2
2
3
4
5
题解:逆向思维裸的并查集
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;
int x[100010],y[100010],ans[100010],s[10010];
int bcj(int t)
{
return t == s[t] ? t : s[t] = bcj(s[t]);
}
int main()
{
int n,m,i;
while(scanf("%d%d",&n,&m)!=EOF)
{
for(i=0;i<n;i++)
s[i]=i;
for(i=0;i<m;i++)
{
scanf("%d%d",&x[i],&y[i]);
}
int temp=n;
for(i=m-1;i>=0;i--)
{
ans[i]=temp;
int p,q;
p=bcj(x[i]);
q=bcj(y[i]);
if(p!=q)
{
temp--;
s[p]=q;
}
}
for(i=0;i<m;i++)
printf("%d\n",ans[i]);
}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: