您的位置:首页 > 其它

HDU 4496 D-City (并查集,水题)

2013-08-24 18:31 260 查看

D-City

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 18 Accepted Submission(s): 15


[align=left]Problem Description[/align]
Luxer is a really bad guy. He destroys everything he met.
One day Luxer went to D-city. D-city has N D-points and M D-lines. Each D-line connects exactly two D-points. Luxer will destroy all the D-lines. The mayor of D-city wants to know how many connected blocks of D-city left after Luxer destroying the first K D-lines in the input.
Two points are in the same connected blocks if and only if they connect to each other directly or indirectly.

[align=left]Input[/align]
First line of the input contains two integers N and M.
Then following M lines each containing 2 space-separated integers u and v, which denotes an D-line.
Constraints:
0 < N <= 10000
0 < M <= 100000
0 <= u, v < N.

[align=left]Output[/align]
Output M lines, the ith line is the answer after deleting the first i edges in the input.

[align=left]Sample Input[/align]

5 10
0 1
1 2
1 3
1 4
0 2
2 3
0 4
0 3
3 4
2 4

[align=left]Sample Output[/align]

1
1
1
2
2
2
2
3
4
5

Hint

The graph given in sample input is a complete graph, that each pair of vertex has an edge connecting them, so there's only 1 connected block at first. The first 3 lines of output are 1s because after deleting the first 3 edges of the graph, all vertexes still connected together. But after deleting the first 4 edges of the graph, vertex 1 will be disconnected with other vertex, and it became an independent connected block. Continue deleting edges the disconnected blocks increased and finally it will became the number of vertex, so the last output should always be N.

[align=left]Source[/align]
2013 ACM-ICPC吉林通化全国邀请赛——题目重现

[align=left]Recommend[/align]
liuyiding

/* ***********************************************
Author        :kuangbin
Created Time  :2013/8/24 12:20:44
File Name     :F:\2013ACM练习\比赛练习\2013通化邀请赛\1004.cpp
************************************************ */

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <math.h>
#include <stdlib.h>
#include <time.h>
using namespace std;
const int MAXN = 10010;
int F[MAXN];
int find(int x)
{
if(F[x] == -1)return x;
return F[x] = find(F[x]);
}
pair<int,int>p[100010];
int ans[100010];
int main()
{
//freopen("in.txt","r",stdin);
//freopen("out.txt","w",stdout);

int n,m;
while(scanf("%d%d",&n,&m) == 2)
{
memset(F,-1,sizeof(F));
for(int i = 1;i <= m;i++)
{
scanf("%d%d",&p[i].first,&p[i].second);
}
ans[m] = n;
for(int i = m;i > 1;i --)
{
int t1 = find(p[i].first);
int t2 = find(p[i].second);
if(t1 != t2)
{
ans[i-1] = ans[i] - 1;
F[t1] = t2;
}
else ans[i-1] = ans[i];
}
for(int i = 1;i <= m;i++)
printf("%d\n",ans[i]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: