您的位置:首页 > 其它

hdu 2844 Coins(dp 多重背包 二进制优化)

2014-08-08 13:59 381 查看


Coins

Time Limit: 2000/1000 MS (Java/Others) Memory
Limit: 32768/32768 K (Java/Others)

Total Submission(s): 7193 Accepted Submission(s): 2925



Problem Description

Whuacmers use coins.They have coins of value A1,A2,A3...An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the
price would not more than m.But he didn't know the exact price of the watch.

You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.

Input

The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed
by two zeros.

Output

For each test case output the answer on a single line.

Sample Input

3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0


Sample Output

[code]8
4
#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#define INF 1000000000
using namespace std;
int a[110],c[110],dp[100010];
void complete_pack(int x , int m)
{
for(int i=x;i<=m;i++)
dp[i]=max(dp[i],dp[i-x]+x);
}
void zeroone_pack(int x , int m)
{
for(int i=m;i>=x;i--)
dp[i]=max(dp[i],dp[i-x]+x);
}
int main()
{
int n,m,i,j;
while(cin>>n>>m,n,m)
{
for(i=1;i<=n;i++)
scanf("%d",&a[i]);
for(i=1;i<=n;i++)
scanf("%d",&c[i]);
for(i=0;i<=m;i++)
dp[i]=0;
for(i=1;i<=n;i++)
{
if(a[i]*c[i]>=m)
complete_pack(a[i],m);
else
{
for(j=1;j<=c[i];j<<=1)//二进制优化 5会变成 1和2和2
{
zeroone_pack(j*a[i],m);
c[i]-=j;
}
if(c[i]>0)
zeroone_pack(c[i]*a[i],m);
}
}
int sum=0;
for(i=1;i<=m;i++)
if(dp[i]==i)
{
sum++;
}
cout<<sum<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: