您的位置:首页 > 其它

poj 3070 Fibonacci 矩阵快速幂

2014-08-07 16:51 344 查看
Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and
Fn = Fn − 1 + Fn − 2 for
n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …
An alternative formula for the Fibonacci sequence is


.
Given an integer n, your goal is to compute the last 4 digits of
Fn.

nput

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤
n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of
Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print
Fn mod 10000).

Sample Input
0
9
999999999
1000000000
-1

Sample Output
0
34
626
6875

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by


.
Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:


.

题意是求斐波那契数,不过给出的是矩阵求法。。

这是矩阵快速幂的模板,其实和常数快速幂一样的原理。

代码:

#include<stdio.h>
#include<string.h>
const int maxn=2;
const int mod=10000;
typedef struct
{
int M[maxn][maxn];
}matrix;
matrix P={1,1,1,0}; //等比矩阵
matrix I={1,0,0,1}; //单位矩阵
matrix multiplies(matrix a,matrix b) //矩阵乘法
{
matrix c;
for(int i=0;i<maxn;i++)
for(int j=0;j<maxn;j++)
{
c.M[i][j]=0;
for(int k=0;k<maxn;k++)
c.M[i][j]+=(a.M[i][k]*b.M[k][j])%mod;
c.M[i][j]%=mod;
}
return c;
}
void pow_mod(__int64 n) //快速幂
{
matrix t=P,ans=I;
while(n)
{
if(n&1)
ans=multiplies(ans,t);
n/=2;
t=multiplies(t,t);
}
printf("%d\n",ans.M[0][0]%mod);
}
int f[maxn];
int main()
{
int n;
while(scanf("%d",&n)!=EOF)
{
if(n==-1) break;
if(n==0)
{
printf("0\n");
continue;
}
pow_mod(n-1);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: