您的位置:首页 > 产品设计 > UI/UE

uva 424 Integer Inquiry (大数加法)

2014-08-07 10:13 85 查看



One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.
``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on
Third Street.)

Input

The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger
will be negative).

The final input line will contain a single zero on a line by itself.

Output

Your program should output the sum of the VeryLongIntegers given in the input.

Sample Input

123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0


Sample Output

370370367037037036703703703670

题解----就是用数组模拟每位相加,最后再进位,注意数组不要从0,1,2,3开始存,
进位可能需要前面的空间
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int a[105],b[105];
char str[105];
void atoi(char c[])//用数组存每一位
{
int p,i;
for(i=strlen(c)-1,p=104;i>=0;i--,p--)
{
b[p]=c[i]-'0';
}
}
int main()
{
int i,q=0;
memset(a,0,sizeof(a));
while(cin>>str)
{
memset(b,0,sizeof(b));
if(strcmp(str,"0")==0)
break;
atoi(str);
for(i=104;i>=0;i--)
{
a[i]=b[i]+a[i];
}
}
for(i=104;i>=0;i--)
{
a[i-1]=a[i-1]+a[i]/10;//进位
a[i]=a[i]%10;//余数
}
for(i=0;i<105;i++)
{
if(a[i]==0&&q==0)
continue;
else
{
cout<<a[i];
q=1;
}
}
puts("");
return 0;
}


[/code]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: