您的位置:首页 > 其它

HDU 1114---Piggy-Bank【一维完全背包】

2014-07-30 19:36 274 查看


Piggy-Bank

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 11686 Accepted Submission(s): 5889

Problem Description

Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea
behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there
should be enough cash in the piggy-bank to pay everything that needs to be paid.

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly,
we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given
currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!

Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights
are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are
exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams.

Output

Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight
cannot be reached exactly, print a line "This is impossible.".

Sample Input

310 11021 130 5010 11021 150 301 6210 320 4


Sample Output

The minimum amount of money in the piggy-bank is 60.The minimum amount of money in the piggy-bank is 100.This is impossible.




解析:本题是01背包的进化版--完全背包。看题:从前,有一只小猪储钱罐,它不装任何硬币的体重已知,装完硬币后的体重也已知,     然后分别给出几种面值的硬币及其重量。问:你觉得它里面的硬币最少是多少钱的。。。。因为硬币可以取无数个,,所以是完全背包。。唉,代码在此。。
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int main()
{
int f[10009],w[505],c[505],m,n,i,j,cas,a,b;
while(~scanf("%d",&cas))
while(cas--)
{
scanf("%d%d",&a,&b);
m=b-a;
scanf("%d",&n);
for(i=0;i<n;i++)
scanf("%d%d",&w[i],&c[i]);
for(i=1;i<=m;i++)
f[i]=1000000;
f[0]=0;
for(i=0;i<n;i++)
for(j=c[i];j<=m;j++)
{
f[j]=min(f[j],f[j-c[i]]+w[i]);
}
if(f[m]!=1000000)
printf("The minimum amount of money in the piggy-bank is %d.\n",f[m]);
else printf("This is impossible.\n");
}
return 0;
}

</pre></div>



内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: