您的位置:首页 > 其它

【二叉树之遍历的应用】HDU 1710---Binary Tree Traversals

2014-07-31 20:28 429 查看


Binary Tree Traversals

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 3270 Accepted Submission(s): 1471



Problem Description

A binary tree is a finite set of vertices that is either empty or consists of a root r and two disjoint binary trees called the left and right subtrees. There are three most important ways in which the vertices of a binary tree can be systematically traversed
or ordered. They are preorder, inorder and postorder. Let T be a binary tree with root r and subtrees T1,T2.

In a preorder traversal of the vertices of T, we visit the root r followed by visiting the vertices of T1 in preorder, then the vertices of T2 in preorder.

In an inorder traversal of the vertices of T, we visit the vertices of T1 in inorder, then the root r, followed by the vertices of T2 in inorder.

In a postorder traversal of the vertices of T, we visit the vertices of T1 in postorder, then the vertices of T2 in postorder and finally we visit r.

Now you are given the preorder sequence and inorder sequence of a certain binary tree. Try to find out its postorder sequence.



Input

The input contains several test cases. The first line of each test case contains a single integer n (1<=n<=1000), the number of vertices of the binary tree. Followed by two lines, respectively indicating the preorder sequence and inorder sequence. You can assume
they are always correspond to a exclusive binary tree.

Output

For each test case print a single line specifying the corresponding postorder sequence.

Sample Input

9
1 2 4 7 3 5 8 9 6
4 7 2 1 8 5 9 3 6


Sample Output

7 4 2 8 9 5 6 3 1根据前序遍历和中序遍历求后序遍历。。。代码:
#include <iostream>
#include <algorithm>
#include<stdio.h>
using namespace std;
int firstsearch[1005];
int midsearch[1005];
void dfs(int first,int mid,int size,int flag)
{
int i;
if(size==1)
{
printf("%d ",firstsearch[first]);
return ;
}
if(size<=0)
return ;
for(i=0;firstsearch[first]!=midsearch[mid+i];i++);
dfs(first+1,mid,i,1);
dfs(first+i+1,mid+i+1,size-i-1,1);
if(flag==0)
printf("%d\n",firstsearch[first]);
else
printf("%d ",firstsearch[first]);
}
int main()
{
int n,i;
while(~scanf("%d",&n))
{
for(i=1;i<=n;i++)
scanf("%d",&firstsearch[i]);
for(i=1;i<=n;i++)
scanf("%d",&midsearch[i]);
dfs(1,1,n,0);
}
return 0;
}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: