您的位置:首页 > 产品设计 > UI/UE

杭电 1005 Number Sequence

2014-07-28 08:55 357 查看
                                                                                                                        
Number Sequence
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 45754 Accepted Submission(s): 10082

Problem Description

A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

Input

The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

Output

For each test case, print the value of f(n) on a single line.

Sample Input
1 1 3  1 2 10  0 0 0


Sample Output
2  5


Author

CHEN, Shunbao

 

 

代码部分:

<----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------->

 

#include"stdio.h"

int main()

{

    int A,B,n,i,f[200];

    while(scanf("%d %d %d",&A,&B,&n)!=EOF)

    {

    

        if(A==0&&B==0&n==0)break;

        if(n<=1)

            {

                printf   ("1\n");

                continue;

            }

        f[1]=1,f[2]=1;

        A%=7,B%=7;

        for(i=3;i<=52;i++)

            {

                f[i]=(A*f[i-1]+B*f[i-2])%7;

                if(f[i-1]==1 && f[i]==1) break;

            }

        i=i-2;

        n%=i;

        f[0]=f[i];

        printf("%d\n",f
);

    }

    return 0;

}

 

<----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------->

 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息