您的位置:首页 > 其它

poj2411 Mondriaan's Dream 插头dp做法

2014-07-25 13:56 441 查看
Mondriaan's Dream

Time Limit: 3000MSMemory Limit: 65536K
Total Submissions: 11379Accepted: 6610
Description

Squares and rectangles fascinated the famous Dutch painter Piet Mondriaan. One night, after producing the drawings in his 'toilet series' (where he had to use his toilet paper to draw on, for all of his paper was filled with squares and rectangles), he dreamt
of filling a large rectangle with small rectangles of width 2 and height 1 in varying ways.



Expert as he was in this material, he saw at a glance that he'll need a computer to calculate the number of ways to fill the large rectangle whose dimensions were integer values, as well. Help him, so that his dream won't turn into a nightmare!
Input

The input contains several test cases. Each test case is made up of two integer numbers: the height h and the width w of the large rectangle. Input is terminated by h=w=0. Otherwise, 1<=h,w<=11.
Output


For each test case, output the number of different ways the given rectangle can be filled with small rectangles of size 2 times 1. Assume the given large rectangle is oriented, i.e. count symmetrical
tilings multiple times.
Sample Input
1 2
1 3
1 4
2 2
2 3
2 4
2 11
4 11
0 0

Sample Output
1
0
1
2
3
5
144
51205

Source

Ulm Local 2000
题意:求用1*2的格子填满n*m的网格的方法数。

思路:用插头dp的思路 ,但这题每个格子只能有一个插头,理解插头dp做后这题很简单,完全不需要考虑回路或障碍。

#include <cstdio>
#include <cstring>
int n,m;
long long dp[2][1<<11];
int main()
{
    while(scanf("%d%d",&n,&m),n||m){
        if(n*m&1) {printf("0\n");continue;}
        memset(dp,0,sizeof(dp));
        dp[0][0]=1;
        int c=1;
        for(int i=0;i<n;i++){
            for(int j=0;j<m;j++){
                c=!c;
                memset(dp[!c],0,sizeof(dp[!c]));
                for(int s=0;s<(1<<m);s++){
                    if(dp[c][s]){
                        dp[!c][s^(1<<j)]+=dp[c][s];
                        if(j>0&&(s&(1<<(j-1)))&&(!(s&(1<<j))))dp[!c][s^(1<<(j-1))]+=dp[c][s];
                    }
                }
            }
        }
        printf("%I64d\n",dp[!c][0]);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: