您的位置:首页 > 其它

[NWPU][2014][TRN][5]二分和贪心 M - 贪心 基础 POJ 2709

2014-07-21 21:24 357 查看
M - 贪心 基础
Time Limit:1000MS Memory Limit:65536KB 64bit IO Format:%I64d
& %I64u
Submit Status Practice POJ
2709

Description

The local toy store sells small fingerpainting kits with between three and twelve 50ml bottles of paint, each a different color. The paints are bright and fun to work with, and have the useful property that if you mix X ml each of any three different colors,
you get X ml of gray. (The paints are thick and "airy", almost like cake frosting, and when you mix them together the volume doesn't increase, the paint just gets more dense.) None of the individual colors are gray; the only way to get gray is by mixing exactly
three distinct colors, but it doesn't matter which three. Your friend Emily is an elementary school teacher and every Friday she does a fingerpainting project with her class. Given the number of different colors needed, the amount of each color, and the amount
of gray, your job is to calculate the number of kits needed for her class.

Input

The input consists of one or more test cases, followed by a line containing only zero that signals the end of the input. Each test case consists of a single line of five or more integers, which are separated by a space. The first integer N is the number of
different colors (3 <= N <= 12). Following that are N different nonnegative integers, each at most 1,000, that specify the amount of each color needed. Last is a nonnegative integer G <= 1,000 that specifies the amount of gray needed. All quantities are in
ml.

Output

For each test case, output the smallest number of fingerpainting kits sufficient to provide the required amounts of all the colors and gray. Note that all grays are considered equal, so in order to find the minimum number of kits for a test case you may need
to make grays using different combinations of three distinct colors.

Sample Input

3 40 95 21 0
7 25 60 400 250 0 60 0 500
4 90 95 75 95 10
4 90 95 75 95 11
5 0 0 0 0 0 333
0


Sample Output

2
8
2
3
4


很巧妙地方法,依次去最小的单种颜色,每次配成一毫升的灰色,最后判断最大的一种颜色所需的总颜料盒数
#include<algorithm>
#include <iostream>
#include<cstdio>
using namespace std;
const int MAXN = 1005;
int n, a[MAXN], g;
int main()
{
while(cin >> n && n)
{
//freopen("D:\input.txt", "r", stdin);
for(int i = 0; i < n; i++)
{
cin >> a[i];
}
cin >> g;
for(int i = 0; i < g; i++)
{
sort(a, a + n);
a[0]++;
a[1]++;
a[2]++;
}
sort(a, a + n);
//sort(a, a + n);
int sum = (int)(a[n - 1] / 50) + (a[n - 1] % 50 == 0 ? 0 : 1);
cout << sum << endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: