您的位置:首页 > 运维架构

POJ 2976 Dropping tests 0/1分数规划问题 最大化平均值 贪心+二分

2014-06-24 11:35 441 查看
Description

In a certain course, you take n tests. If you get ai out of bi questions correct on test i, your cumulative average is defined to be


.

Given your test scores and a positive integer k, determine how high you can make your cumulative average if you are allowed to drop any k of your test scores.

Suppose you take 3 tests with scores of 5/5, 0/1, and 2/6. Without dropping any tests, your cumulative average is . However, if you drop the third test, your cumulative average becomes .

Input

The input test file will contain multiple test cases, each containing exactly three lines. The first line contains two integers, 1 ≤ n ≤ 1000 and 0 ≤ k < n. The second line contains n integers indicating ai for all i. The third line contains n positive integers
indicating bi for all i. It is guaranteed that 0 ≤ ai ≤ bi ≤ 1, 000, 000, 000. The end-of-file is marked by a test case with n = k = 0 and should not be processed.

Output

For each test case, write a single line with the highest cumulative average possible after dropping k of the given test scores. The average should be rounded to the nearest integer.

Sample Input

3 1

5 0 2

5 1 6

4 2

1 2 7 9

5 6 7 9

0 0

Sample Output

83

100

Hint

To avoid ambiguities due to rounding errors, the judge tests have been constructed so that all answers are at least 0.001 away from a decision boundary (i.e., you can assume that the average is never 83.4997).

方法:可行函数单调递减,想到用二分快速搜索,可行函数是线性的,满足贪心原理

#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;

const double eps = 1e-4;
int a[1005], b[1005];
double f[1005];
int n, k;

bool cmp(double i, double j){
return i > j;
}

bool C(double v){
for(int i=0; i<n; i++)
f[i] = a[i] - v*b[i];
sort(f, f+n, cmp);
double sum = 0;
for(int i=0; i<n-k; i++)
sum += f[i];
if(sum >= 0) return 1;
else return 0;
}

int main(){
while(scanf("%d %d", &n, &k) == 2){
if(n==0 && k==0) break;
for(int i=0; i<n; i++)
scanf("%d", &a[i]);
for(int i=0; i<n; i++)
scanf("%d", &b[i]);
double lb = 0, ub = 1.0;
while(ub - lb > eps){
double mid = (lb+ub)/2;
if(C(mid)) lb = mid;
else ub = mid;
}
printf("%.0lf\n", lb*100);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: