您的位置:首页 > 其它

[NWPU][2014][TRN][5]二分和贪心 HDU 4296

2014-07-22 18:53 429 查看
N - 贪心
Time Limit:2000MS Memory Limit:32768KB 64bit IO Format:%I64d
& %I64u
Submit Status Practice HDU
4296

Description

  Have you ever heard the story of Blue.Mary, the great civil engineer? Unlike Mr. Wolowitz, Dr. Blue.Mary has accomplished many great projects, one of which is the Guanghua Building.

  The public opinion is that Guanghua Building is nothing more than one of hundreds of modern skyscrapers recently built in Shanghai, and sadly, they are all wrong. Blue.Mary the great civil engineer had try a completely new evolutionary building method in
project of Guanghua Building. That is, to build all the floors at first, then stack them up forming a complete building.

  Believe it or not, he did it (in secret manner). Now you are face the same problem Blue.Mary once stuck in: Place floors in a good way.

  Each floor has its own weight w i and strength s i. When floors are stacked up, each floor has PDV(Potential Damage Value) equal to (Σw j)-s i, where (Σw j) stands for sum of weight of all floors above.

  Blue.Mary, the great civil engineer, would like to minimize PDV of the whole building, denoted as the largest PDV of all floors.

  Now, it’s up to you to calculate this value.

Input

  There’re several test cases.

  In each test case, in the first line is a single integer N (1 <= N <= 10 5) denoting the number of building’s floors. The following N lines specify the floors. Each of them contains two integers w i and s i (0 <= w i,
s i <= 100000) separated by single spaces.

  Please process until EOF (End Of File).

Output

  For each test case, your program should output a single integer in a single line - the minimal PDV of the whole building.

  If no floor would be damaged in a optimal configuration (that is, minimal PDV is non-positive) you should output 0.

Sample Input

3
10 6
2 3
5 4
2
2 2
2 2
3
10 3
2 5
3 3


Sample Output

1
0
2


//刚开始用的int结果wa了
#include<iostream> //“一键”导入c++的所有头文件
using namespace std;
//typedef long long  ll;
#define ll long long  //两种定义long long 为ll的方式
ll  n, w, s;
int main()
{
while(cin >> n)
{
ll maxa = 0, sum = 0;
for(int i = 0; i < n ;i++)
{
cin >> w >> s;
sum += w;
maxa = max(maxa, w + s);
}
//int ans = sum - w;
ll ans = sum - maxa;
cout << (ans > 0 ? ans : 0 ) << endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: