您的位置:首页 > 其它

poj1861--Network(最小生成树)

2014-06-07 17:44 295 查看
Description

Andrew is working as
system administrator and is planning to establish a new network in
his company. There will be N hubs in the company, they can be
connected to each other using cables. Since each worker of the
company must have access to the whole network, each hub must be
accessible by cables from any other hub (with possibly some
intermediate hubs).

Since cables of different types are available and shorter ones are
cheaper, it is necessary to make such a plan of hub connection,
that the maximum length of a single cable is minimal. There is
another problem — not each hub can be connected to any other one
because of compatibility problems and building geometry
limitations. Of course, Andrew will provide you all necessary
information about possible hub connections.

You are to help Andrew to find the way to connect hubs so that all
above conditions are satisfied.

Input

The first line of
the input contains two integer numbers: N - the number of hubs in
the network (2 <= N <= 1000) and M -
the number of possible hub connections (1 <= M
<= 15000). All hubs are numbered from 1 to N. The
following M lines contain information about possible connections -
the numbers of two hubs, which can be connected and the cable
length required to connect them. Length is a positive integer
number that does not exceed 106. There will be no more
than one way to connect two hubs. A hub cannot be connected to
itself. There will always be at least one way to connect all
hubs.
Output

Output first the
maximum length of a single cable in your hub connection plan (the
value you should minimize). Then output your plan: first output P -
the number of cables used, then output P pairs of integer numbers -
numbers of hubs connected by the corresponding cable. Separate
numbers by spaces and/or line breaks.
Sample Input

4 6
1 2 1
1 3 1
1 4 2
2 3 1
3 4 1
2 4 1

Sample Output

1

4

1 2

1 3

2 3

3 4

 

/////////////////////////////

上面的样例有错误!!!

# include<stdio.h>

# include<stdlib.h>

struct node {

      
int x,y,lenth;

};

struct node road[15010],mark[15010];

int set[1005],map[1005][1005];

int cmp(void const *a,void const *b)

{

      
struct node *c,*d;

      
c=(struct node *)a;

      
d=(struct node *)b;

      
return c->lenth-d->lenth;

}

int find(int x)

{

      
if(set[x]!=x)

             
set[x]=find(set[x]);

      
return set[x];

}

int main()

{

      
int i,n,m,a,b,c,max,count;

      
scanf("%d%d",&n,&m);

      
for(i=1;i<=n;i++)

             
set[i]=i;

      
for(i=0;i<m;i++)

      
{

             
scanf("%d%d%d",&a,&b,&c);

             
road[i].x=a;

             
road[i].y=b;

             
road[i].lenth=c;

 

      
}

      
qsort(road,m,sizeof(road[0]),cmp);

      
max=count=0;

      
for(i=0;i<m;i++)

      
{

             
a=find(road[i].x);

             
b=find(road[i].y);

             
if(a==b)

                    
continue;

             
else

             
{

                    
if(max<road[i].lenth)

                           
max=road[i].lenth;

                    
count++;

                    
mark[count]=road[i];

                    
if(a<b)

                           
set[b]=a;

                    
else

                           
set[a]=b;

             
}

      
}

      
printf("%d\n",max);

      
printf("%d\n",count);

      
for(i=1;i<=count;i++)

             
printf("%d %d\n",mark[i].x,mark[i].y);

      
return 0;

}

 

 

 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: