您的位置:首页 > 其它

POJ 1861 Network (Kruskal算法+输出的最小生成树里最长的边==最后加入生成树的边权 *【模板】)

2015-01-22 10:56 639 查看
Network

Time Limit: 1000MSMemory Limit: 30000K
Total Submissions: 14021Accepted: 5484Special Judge
Description

Andrew is working as system administrator and is planning to establish a new network in his company. There will be N hubs in the company, they can be connected to each other using cables. Since each worker of the company must have access to the whole network, each hub must be accessible by cables from any other hub (with possibly some intermediate hubs).
Since cables of different types are available and shorter ones are
cheaper, it is necessary to make such a plan of hub connection, that the
maximum length of a single cable is minimal. There is another problem —
not each hub can be connected to any other one because of compatibility
problems and building geometry limitations. Of course, Andrew will
provide you all necessary information about possible hub connections.

You are to help Andrew to find the way to connect hubs so that all above conditions are satisfied.

Input

The
first line of the input contains two integer numbers: N - the number of
hubs in the network (2 <= N <= 1000) and M - the number of
possible hub connections (1 <= M <= 15000). All hubs are numbered
from 1 to N. The following M lines contain information about possible
connections - the numbers of two hubs, which can be connected and the
cable length required to connect them. Length is a positive integer
number that does not exceed 106. There will be no more than
one way to connect two hubs. A hub cannot be connected to itself. There
will always be at least one way to connect all hubs.
Output

Output
first the maximum length of a single cable in your hub connection plan
(the value you should minimize). Then output your plan: first output P -
the number of cables used, then output P pairs of integer numbers -
numbers of hubs connected by the corresponding cable. Separate numbers
by spaces and/or line breaks.
Sample Input

4 6
1 2 1
1 3 1
1 4 2
2 3 1
3 4 1
2 4 1

Sample Output

1
4
1 2
1 3
2 3
3 4

题目分析:北大poj的原题目样例有问题,Sample Output是错的。开始我也不知道那个样例的输出是怎样出来的!
毕竟4个节点只需要3条边就可以全部连接了,而样例的却是4条。网上看了一下别人的博客才知道阳历是错的。并且
输出的生成树的边的方案不唯一。我的输出结果是这样的:



Accepted的代码如下:(第一次Runtime Error了, 结构体数组开小了,注意:边数最多是:15000条,而点数是:1000个)


#include <stdio.h>
#include <string.h>
#include <iostream>
#include <string>
#include <algorithm>

using namespace std;

//模板的Kruskal算法
struct node
{
int u;
int v;
int w;
bool operator <(const node &x)const
{
return w<x.w;
}
}q[15002];
int e;

int fa[1002];
int dd[1002][2], k=0;

int findset(int x)
{
return fa[x]!=x?fa[x]=findset(fa[x]):x;
}
int main()
{
int n, m;
scanf("%d %d", &n, &m);
int i, j;
e=0;
for(i=0; i<m; i++ )
{
scanf("%d %d %d", &q[e].u, &q[e].v, &q[e].w );
e++;
}
sort(q+0, q+e ); //
for(i=0; i<=n; i++)
{
fa[i]=i;
}
int cnt=0; //边数计数器
int mm; //save the max path weight
for(j=0; j<e; j++)
{
if(findset(q[j].u) != findset(q[j].v) )
{
fa[ fa[q[j].u] ] = fa[q[j].v];
dd[k][0]=q[j].u; dd[k][1]=q[j].v; k++;

cnt++;
if(cnt==n-1)
{
mm=q[j].w;
break;
}
}
}
printf("%d\n%d\n", mm, cnt );
for(i=0; i<k; i++)
{
printf("%d %d\n", dd[i][0], dd[i][1] );
}

return 0;
}



                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: