您的位置:首页 > 运维架构

River Hopscotch - POJ 3258 二分

2014-05-29 14:57 309 查看
River Hopscotch

Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 6314Accepted: 2738
Description

Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units
away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di <L).

To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in
order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to M rocks (0 ≤ M ≤ N).

FJ wants to know exactly how much he can increase the shortest distance *before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks.

Input

Line 1: Three space-separated integers: L, N, and M

Lines 2..N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.
Output

Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing M rocks
Sample Input
25 5 2
2
14
11
21
17

Sample Output
4

Hint

Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).

题意:问你去掉M个石后最短的最长距离是多少。

思路:二分结果,看如果要是这个结果的话,需要去掉多少个石头。

AC代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int sl,n,m,stone[50010];
bool solve(int len)
{ int ans=0,i,j=0;
  for(i=1;i<=n+1;i++)
   if(stone[i]-stone[j]<len)
    ans++;
   else
    j=i;
  if(ans<=m)
   return true;
  else
   return false;
}
int divi(int l,int r)
{ int ans=sl+100;
  while(l<=r)
  { int k=(l+r)/2;
    if(solve(k))
     l=k+1;
    else
    { ans=min(ans,k);
      r=k-1;
    }
  }
  return r;
}
int main()
{ int i,j,k;
  scanf("%d%d%d",&sl,&n,&m);
  for(i=1;i<=n;i++)
   scanf("%d",&stone[i]);
  sort(stone+1,stone+1+n);
  stone[0]=0;
  stone[n+1]=sl;
  k=divi(0,sl);
  printf("%d\n",k);
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: