您的位置:首页 > 其它

简单的栈操作的模拟,入栈出栈

2014-04-22 15:54 225 查看
杭电ACM 2014暑期集训队——选拔安排~

Train Problem I

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 19090 Accepted Submission(s): 7150



Problem Description

As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one
railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can't leave until train
B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the
trains can get out in an order O2.







Input

The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample
Input.

Output

The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out" for a train getting out of
the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.

Sample Input

3 123 321
3 123 312


Sample Output

Yes.
in
in
in
out
out
out
FINISH
No.
FINISH

HintHint
For the first Sample Input, we let train 1 get in, then train 2 and train 3.
So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1.
In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3.
Now we can let train 3 leave.
But after that we can't let train 1 leave before train 2, because train 2 is at the top of the railway at the moment.
So we output "No.".
代码如下,sta数组用来存放没有匹配成功的,flag数组标记出入栈的信息,具体的操作需要大家花时间自己动手看一下具体的实现过程#include<stdio.h>
#include<string.h>
char in[100],out[100];
int flag[200];
int sta[200];
int main()
{
int n;
int top;
int i,j,k;
int ok;
while(scanf("%d",&n)!=EOF)
{

scanf("%s%s",&in,&out);
top=0;
i=j=k=0;
ok=1;
while(j<n)
{
if(in[i]==out[j])
{
flag[k++]=0;
flag[k++]=1;
i++;
j++;
}
else if(top>0 && sta[top-1]==out[j])
{
flag[k++]=1;
top--;
j++;
}
else if(i<n)
{
sta[top++]=in[i++];
flag[k++]=0;

}
else
{
ok=0;
break;
}
}
if(ok==0) printf("No.\n");
else
{
printf("Yes.\n");
for(int p=0;p<k;p++)
{
if(flag[p]==0)
printf("in\n");
else printf("out\n");
}
}
printf("FINISH\n");
}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: