您的位置:首页 > 其它

hdoj - 1240 - Asteroids!(三维空间的BFS)

2014-04-21 20:09 351 查看
其实很水。。。按二维做就好。。

Asteroids!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 3116    Accepted Submission(s): 2080

[align=left]Problem Description[/align]
You're in space.

You want to get home.

There are asteroids.

You don't want to hit them.

 

[align=left]Input[/align]
Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets.

A single data set has 5 components:

Start line - A single line, "START N", where 1 <= N <= 10.

Slice list - A series of N slices. Each slice is an N x N matrix representing a horizontal slice through the asteroid field. Each position in the matrix will be one of two values:

'O' - (the letter "oh") Empty space

'X' - (upper-case) Asteroid present

Starting Position - A single line, "A B C", denoting the <A,B,C> coordinates of your craft's starting position. The coordinate values will be integers separated by individual spaces.

Target Position - A single line, "D E F", denoting the <D,E,F> coordinates of your target's position. The coordinate values will be integers separated by individual spaces.

End line - A single line, "END"

The origin of the coordinate system is <0,0,0>. Therefore, each component of each coordinate vector will be an integer between 0 and N-1, inclusive.

The first coordinate in a set indicates the column. Left column = 0.

The second coordinate in a set indicates the row. Top row = 0.

The third coordinate in a set indicates the slice. First slice = 0.

Both the Starting Position and the Target Position will be in empty space.

 

[align=left]Output[/align]
For each data set, there will be exactly one output set, and there will be no blank lines separating output sets.

A single output set consists of a single line. If a route exists, the line will be in the format "X Y", where X is the same as N from the corresponding input data set and Y is the least number of moves necessary to get your ship from the starting position to
the target position. If there is no route from the starting position to the target position, the line will be "NO ROUTE" instead.

A move can only be in one of the six basic directions: up, down, left, right, forward, back. Phrased more precisely, a move will either increment or decrement a single component of your current position vector by 1.

 

[align=left]Sample Input[/align]

START 1
O
0 0 0
0 0 0
END
START 3
XXX
XXX
XXX
OOO
OOO
OOO
XXX
XXX
XXX
0 0 1
2 2 1
END
START 5
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
XXXXX
XXXXX
XXXXX
XXXXX
XXXXX
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
0 0 0
4 4 4
END

 

[align=left]Sample Output[/align]

1 0
3 4
NO ROUTE

 

[align=left]Source[/align]
South Central USA 2001 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
const int N = 15;

struct Point{
int x, y, z;
int step;
}start, over, fr, next;
char mp

;
int vis

;
int dir[6][3] = {1, 0, 0, -1, 0, 0, 0, 1, 0, 0, -1, 0, 0, 0, 1, 0, 0, -1};
int n;

void bfs(){
queue<Point> Q;
Q.push(start);
while(!Q.empty()){
fr = Q.front();
// printf("%d %d %d\n", fr.x, fr.y, fr.z);
Q.pop();
if(fr.x - 1 == over.x && fr.y - 1 == over.y && fr.z - 1 == over.z){
printf("%d %d\n", n, fr.step);
return ;
}
for(int i = 0; i < 6; i++){
int xx = fr.x + dir[i][0];
int yy = fr.y + dir[i][1];
int zz = fr.z + dir[i][2];
if(mp[zz][xx][yy] == '\0' || mp[zz][xx][yy] == 'X') continue;
if(!vis[zz][xx][yy]){
vis[zz][xx][yy] = 1;
next.x = xx;
next.y = yy;
next.z = zz;
next.step = fr.step + 1;
Q.push(next);
}
}
}
puts("NO ROUTE");
return;
}

int main(){
char str[10];
while(scanf("%s %d", str, &n) != EOF){
memset(mp, '\0', sizeof(mp));
for(int i = 1; i <= n; i++){
for(int j = 1; j <= n; j++)
scanf("%s", mp[i][j] + 1);
}
scanf("%d%d%d", &start.x, &start.y, &start.z);
start.x++; start.y++; start.z++;
start.step = 0;
scanf("%d%d%d", &over.x, &over.y, &over.z);
scanf("%s", str);
bfs();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: