您的位置:首页 > 其它

HDU 1240 Asteroids! (三维BFS)

2016-06-04 00:26 309 查看

Asteroids!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s):
4704    Accepted Submission(s): 3030

[align=left]Problem Description[/align]
You're in space.

You want to get home.

There are asteroids.

You don't want to hit them.
[align=left]Input[/align]
Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data
sets.

A single data set has 5 components:

Start line - A single line, "START N", where 1 <= N <= 10.

Slice list - A series of N slices. Each slice is an N x N matrix representing a horizontal slice through the asteroid field. Each position in the matrix will be one of two values:

'O' - (the letter "oh") Empty space

'X' - (upper-case) Asteroid present

Starting Position - A single line, "A B C", denoting the <A,B,C> coordinates of your craft's starting position. The coordinate values will be integers separated by individual spaces.

Target Position - A single line, "D E F", denoting the <D,E,F> coordinates of your target's position. The coordinate values will be integers separated by individual spaces.

End line - A single line, "END"

The origin of the coordinate system is <0,0,0>. Therefore, each component of each coordinate vector will be an integer between 0 and N-1, inclusive.

The first coordinate in a set indicates the column. Left column = 0.

The second coordinate in a set indicates the row. Top row = 0.

The third coordinate in a set indicates the slice. First slice = 0.

Both the Starting Position and the Target Position will be in empty space.

[align=left]Output[/align]
For each data set, there will be exactly one output set, and there will be no blank lines separating output sets.

A single output set consists of a single line. If a route exists, the line will be in the format "X Y", where X is the same as N from the corresponding input data set and Y is the least number of moves necessary to get your ship from the starting position to
the target position. If there is no route from the starting position to the target position, the line will be "NO ROUTE" instead.

A move can only be in one of the six basic directions: up, down, left, right, forward, back. Phrased more precisely, a move will either increment or decrement a single component of your current position vector by 1.

[align=left]Sample Input[/align]

START 1
O
0 0 0
0 0 0
END
START 3
XXX
XXX
XXX
OOO
OOO
OOO
XXX
XXX
XXX
0 0 1
2 2 1
END
START 5
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
XXXXX
XXXXX
XXXXX
XXXXX
XXXXX
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
0 0 0
4 4 4
END

[align=left]Sample Output[/align]

1 0
3 4
NO ROUTE

[align=left]Source[/align]
South Central USA 2001

题解:有一个三维立体图,x代表行星,o代表太空,然后给你一个三维的起点和终点,求起点到终点的最短距离,最后到的一定是行星,不能留在太空,途中不能撞到其他行星。

三维的BFS。。。

AC代码:

#include<iostream>
#include<cstring>
#include<queue>
#include<stdio.h>
#define max 11
using namespace std;
char map[max][max][max];
int vis[max][max][max];
int n;
int st1,st2,st3,en1,en2,en3;
int step;
struct Q
{

int x,y,z;
int step;
};
void bfs()
{
step=0;
memset(vis,0,sizeof(vis));
queue<Q> q;
Q temp,now;

temp.x=st1;
temp.y=st2;
temp.z=st3;
temp.step=0;
vis[temp.x][temp.y][temp.z]=1;
q.push(temp);
int i,j,k;
int x[6]={ 1,-1, 0, 0,  0, 0};
int y[6]={ 0, 0, 1, -1, 0, 0};
int z[6]={ 0, 0, 0, 0,  1, -1};
while(!q.empty())
{
now=q.front();
q.pop();
int a,b,c;
for(i=0;i<6;i++)
{
a=now.x+x[i];
b=now.y+y[i];
c=now.z+z[i];
if(a==en1&&b==en2&&c==en3)
{
step=now.step+1;
return;
}
if(a>=0&&b>=0&&c>=0&&a<n&&b<n&&c<n&&vis[a][b][c]==0&&map[a][b][c]=='O')
{
vis[a][b][c]=1;
temp.x=a;
temp.y=b;
temp.z=c;
temp.step=now.step+1;
q.push(temp);
}
}
}

}
int main()
{
int i,j;
char s[10];
while(scanf("%s%d",s,&n)!=EOF)
{
memset(map,0,sizeof(map));
for(i=0;i<n;i++)
{

for(j=0;j<n;j++)
{

getchar();
scanf("%s",map[i][j]);
}
}
scanf("%d%d%d%d%d%d",&st1,&st2,&st3,&en1,&en2,&en3);
getchar();
scanf("%s",s);
if(st1==en1&&st2==en2&&st3==en3)
{
printf("%d %d\n",n,0);
continue;
}
bfs();
if(step)
{
printf("%d %d\n",n,step);
}
else{
printf("NO ROUTE\n");
}
}
return 0;
}


discuss上的参考更容易明白:

#include<stdio.h>
#include<queue>
using namespace std;
char map[10][10][10];
int startx,starty,startz,endx,endy,endz;
int n;
struct node
{
int x,y,z,step;
friend bool operator <(node a,node b)
{
return a.step>b.step;
}
};
void bfs(int x1,int y1,int z1,int x2,int y2,int z2)
{
int k;
int move[6][3]={{0,0,1},{0,0,-1},{0,1,0},{0,-1,0},{1,0,0},{-1,0,0}};
node now,next;
priority_queue<node>q;
now.x=x1;
now.y=y1;
now.z=z1;
now.step=0;
map[now.x][now.y][now.z]='X';
q.push(now);
while(!q.empty())
{
next=q.top();
q.pop();
if(next.x==x2&&next.y==y2&&next.z==z2)
{
printf("%d %d\n",n,next.step);
return ;
}
for(k=0;k<6;k++)
{
now.x=next.x+move[k][0];
now.y=next.y+move[k][1];
now.z=next.z+move[k][2];
if(now.x>=0&&now.x<n&&now.y>=0&&now.y<n&&now.z>=0&&now.z<n&&map[now.x][now.y][now.z]=='O')
{
now.step=next.step+1;
map[now.x][now.y][now.z]='X';
q.push(now);
}
}
}
printf("NO ROUTE\n");
}
int main()
{
int i,j,k;
char s[10];
while(scanf("%s %d",s,&n)!=EOF)
{
getchar();
for(i=0;i<n;i++)
{
for(j=0;j<n;j++)
{
for(k=0;k<n;k++)
{
scanf("%c",&map[i][j][k]);
}
getchar();
}
getchar();
}
scanf("%d%d%d%d%d%d",&startx,&starty,&startz,&endx,&endy,&endz);
scanf("%s",s);
bfs(startx,starty,startz,endx,endy,endz);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: