您的位置:首页 > 其它

POJ 2774 Long Long Message 求两个串最长公共子串(后缀数组)

2014-04-09 17:25 676 查看
点击打开链接

Long Long Message

Time Limit: 4000MS Memory Limit: 131072K
Total Submissions: 19413 Accepted: 8019
Case Time Limit: 1000MS
Description
The little cat is majoring in physics in the capital of Byterland. A piece of sad news comes to him these days: his mother is getting ill. Being worried about spending so much on railway tickets (Byterland is such a big country,
and he has to spend 16 shours on train to his hometown), he decided only to send SMS with his mother.

The little cat lives in an unrich family, so he frequently comes to the mobile service center, to check how much money he has spent on SMS. Yesterday, the computer of service center was broken, and printed two very long messages. The brilliant little cat soon
found out:

1. All characters in messages are lowercase Latin letters, without punctuations and spaces.

2. All SMS has been appended to each other – (i+1)-th SMS comes directly after the i-th one – that is why those two messages are quite long.

3. His own SMS has been appended together, but possibly a great many redundancy characters appear leftwards and rightwards due to the broken computer.

E.g: if his SMS is “motheriloveyou”, either long message printed by that machine, would possibly be one of “hahamotheriloveyou”, “motheriloveyoureally”, “motheriloveyouornot”, “bbbmotheriloveyouaaa”, etc.

4. For these broken issues, the little cat has printed his original text twice (so there appears two very long messages). Even though the original text remains the same in two printed messages, the redundancy characters on both sides would be possibly different.

You are given those two very long messages, and you have to output the length of the longest possible original text written by the little cat.

Background:

The SMS in Byterland mobile service are charging in dollars-per-byte. That is why the little cat is worrying about how long could the longest original text be.

Why ask you to write a program? There are four resions:

1. The little cat is so busy these days with physics lessons;

2. The little cat wants to keep what he said to his mother seceret;

3. POJ is such a great Online Judge;

4. The little cat wants to earn some money from POJ, and try to persuade his mother to see the doctor :(

Input
Two strings with lowercase letters on two of the input lines individually. Number of characters in each one will never exceed 100000.
Output
A single line with a single integer number – what is the maximum length of the original text written by the little cat.
Sample Input
yeshowmuchiloveyoumydearmotherreallyicannotbelieveit
yeaphowmuchiloveyoumydearmother

Sample Output
27

Source
POJ Monthly--2006.03.26,Zeyuan Zhu,"Dedicate to my great beloved mother."

给你两个字符串,让你求它们的最长公共子串。

字符串的任何一个子串都是这个字符串的某个后缀的前缀。 A 和 B 的最长求公共子串等价于求 A 的后缀和 B 的后缀的最长公共前缀的最大值。如果枚举 A和 B 的所有的后缀,那么这样做显然效率低下。由于要计算 A 的后缀和 B 的后缀的最长公共前缀,所以先将第二个字符串写在第一个字符串后面,中间用一个没有出现过的字符隔开,再求这个新的字符的后缀数组。那么是不是所有的 height 值中的最大值就是答案呢?不一定!有可能这两个 后 缀 是 在 同 一 个 字 符 串 中 的 , 所 以 实 际 上 只 有 当
suffix(sa[i-1]) 和suffix(sa[i])不同一个字符串中的两个后缀时,height[i]才是满足条件的。而这其中的最大值就是答案。记字符串 A 和字符串 B 的长度分别为|A|和|B|。求新的字符串的后缀数组和 height 数组的时间是 O(|A|+|B|),然后求排名相邻但原 来 不 在 同 一 个 字 符 串 中 的 两 个 后 缀 的 height 值 的 最 大 值 , 时 间 也 是O(|A|+|B|),所以整个做法的时间复杂度为 O(|A|+|B|)。时间杂度已经取到下限,由此看出,这是一个非常优秀的算法。

摘自罗穗骞的《处理字符串的有力工具》。

//5808K	360MS
#include<stdio.h>
#include<string.h>
#include<algorithm>
#define MAX 200010
#define inf 0x3f3f3f3f
using namespace std;
int sa[MAX],rank[MAX],height[MAX];
int wa[MAX],wb[MAX],wv[MAX],ws[MAX];
int num[MAX];
char s1[MAX],s[MAX];
int len;
int cmp(int *r,int a,int b,int l)
{
return r[a]==r[b]&&r[a+l]==r[b+l];
}
void get_sa(int *r,int n,int m)//求get函数
{
int i,j,p,*x=wa,*y=wb,*t;
for(i=0; i<m; i++)ws[i]=0;
for(i=0; i<n; i++)ws[x[i]=r[i]]++;
for(i=1; i<m; i++)ws[i]+=ws[i-1];
for(i=n-1; i>=0; i--)sa[--ws[x[i]]]=i;
for(j=1,p=1; p<n; j*=2,m=p)
{
for(p=0,i=n-j; i<n; i++)y[p++]=i;
for(i=0; i<n; i++)if(sa[i]>=j)y[p++]=sa[i]-j;
for(i=0; i<n; i++)wv[i]=x[y[i]];
for(i=0; i<m; i++)ws[i]=0;
for(i=0; i<n; i++)ws[wv[i]]++;
for(i=1; i<m; i++)ws[i]+=ws[i-1];
for(i=n-1; i>=0; i--)sa[--ws[wv[i]]]=y[i];
for(t=x,x=y,y=t,p=1,x[sa[0]]=0,i=1; i<n; i++)
x[sa[i]]=cmp(y,sa[i-1],sa[i],j)?p-1:p++;
}
}
void get_height(int *r,int n)//求height函数
{
int i,j,k=0;
for(i=1; i<n; i++)rank[sa[i]]=i; //求rank函数
for(i=0; i<n; height[rank[i++]]=k)
for(k?k--:0,j=sa[rank[i]-1]; r[i+k]==r[j+k]; k++);
}
int solve(int n)
{
int maxx=0;
for(int i=1; i<=n; i++)
if(height[i]>maxx&&((sa[i]<len&&sa[i-1]>len)||(sa[i]>len&&sa[i-1]<len)))//判断最长前缀是不是在同一个串里面
maxx=height[i];
return maxx;
}
int main()
{
//freopen("in.txt","r",stdin);
while(scanf("%s%s",s,s1)!=EOF)
{
len=strlen(s);
s[len]='$';
strcat(s,s1);
int n=strlen(s);
for(int i=0; i<n; i++)
if(s[i]>='a'&&s[i]<='z')num[i]=s[i]-'a'+1;
else num[i]=28;
get_sa(num,n+1,30);
get_height(num,n);
printf("%d\n",solve(n));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: