您的位置:首页 > 其它

POJ 2774 long long message(后缀数组求最长公共子串)

2015-09-18 19:00 555 查看
Long Long Message

Time Limit: 4000MS Memory Limit: 131072K
Total Submissions: 24078 Accepted: 9849
Case Time Limit: 1000MS
Description

The little cat is majoring in physics in the capital of Byterland. A piece of sad news comes to him these days: his mother is getting ill. Being worried about spending so much on railway tickets (Byterland is such a big country, and he has to spend 16 shours
on train to his hometown), he decided only to send SMS with his mother. 

The little cat lives in an unrich family, so he frequently comes to the mobile service center, to check how much money he has spent on SMS. Yesterday, the computer of service center was broken, and printed two very long messages. The brilliant little cat soon
found out: 

1. All characters in messages are lowercase Latin letters, without punctuations and spaces. 

2. All SMS has been appended to each other – (i+1)-th SMS comes directly after the i-th one – that is why those two messages are quite long. 

3. His own SMS has been appended together, but possibly a great many redundancy characters appear leftwards and rightwards due to the broken computer. 

E.g: if his SMS is “motheriloveyou”, either long message printed by that machine, would possibly be one of “hahamotheriloveyou”, “motheriloveyoureally”, “motheriloveyouornot”, “bbbmotheriloveyouaaa”, etc. 

4. For these broken issues, the little cat has printed his original text twice (so there appears two very long messages). Even though the original text remains the same in two printed messages, the redundancy characters on both sides would be possibly different. 

You are given those two very long messages, and you have to output the length of the longest possible original text written by the little cat. 

Background: 

The SMS in Byterland mobile service are charging in dollars-per-byte. That is why the little cat is worrying about how long could the longest original text be. 

Why ask you to write a program? There are four resions: 

1. The little cat is so busy these days with physics lessons; 

2. The little cat wants to keep what he said to his mother seceret; 

3. POJ is such a great Online Judge; 

4. The little cat wants to earn some money from POJ, and try to persuade his mother to see the doctor :( 

Input

Two strings with lowercase letters on two of the input lines individually. Number of characters in each one will never exceed 100000.
Output

A single line with a single integer number – what is the maximum length of the original text written by the little cat.
Sample Input
yeshowmuchiloveyoumydearmotherreallyicannotbelieveit
yeaphowmuchiloveyoumydearmother

Sample Output
27


#include <iostream>
#include <cstring>
#include <cstdlib>
#include <cstdio>
#include <cmath>
#include <algorithm>
#define LL long long
using namespace std;
const int MAXN = 200000 + 10;
int n, k;
int rank[MAXN], tmp[MAXN];
bool compare_sa(int i, int j)
{
if(rank[i] != rank[j]) return rank[i] < rank[j];
else
{
int ri = i + k <= n ? rank[i + k] : -1;
int rj = j + k <= n ? rank[j + k] : -1;
return ri < rj;
}
}
void construct_sa(string s, int *sa)
{
n = s.length();
for(int i=0;i<=n;i++)
{
sa[i] = i;
rank[i] = i < n ? s[i] : -1;
}
for(k=1;k<=n;k<<=1)
{
sort(sa, sa + n + 1, compare_sa);
tmp[sa[0]] = 0;
for(int i=1;i<=n;i++)
{
tmp[sa[i]] = tmp[sa[i-1]] + (compare_sa(sa[i-1], sa[i]) ? 1 : 0);
}
for(int i=0;i<n;i++)
{
rank[i] = tmp[i];
}
}
}
void construct_lcp(string s, int *sa, int *lcp)
{
n = s.length();
for(int i=0;i<=n;i++) rank[sa[i]] = i;
int h = 0; lcp[0] = 0;
for(int i=0;i<n;i++)
{
int j = sa[rank[i]-1];
if(h > 0) h--;
for(;j+h<n && i + h < n;h++)
{
if(s[j + h] != s[i + h]) break;
}
lcp[rank[i] - 1] = h;
}
}
string s, t;
int lcp[MAXN], sa[MAXN];
int main()
{
while(cin >> s >> t)
{
int s1 = s.length();
s += '$'; s += t;
construct_sa(s, sa);
construct_lcp(s, sa, lcp);

int ans = 0, len = s.length();
for(int i=0;i<len;i++)
{
if((sa[i] < s1) != (sa[i+1] < s1))
ans = max(ans, lcp[i]);
}
printf("%d\n", ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: