您的位置:首页 > 产品设计 > UI/UE

poj 2785 二分问题 4 Values whose Sum is 0

2014-02-23 18:10 162 查看
http://poj.org/problem?id=278

Description

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .
Input

The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 228 ) that belong respectively to A, B, C and D .
Output

For each input file, your program has to write the number quadruplets whose sum is zero.
Sample Input
6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45

Sample Output
5

Hint

Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).
从每一列里各取一个数,求有多少组四个数的和加起来为零。

先分别求出前两列后两列的所有的和,然后对后两列的和进行排序,对后两列进行二分查找看有多少种情况即可!

枚举会超时的

#include <stdio.h>
#include <iostream>
#include <string.h>
#include <algorithm>
using namespace std;
int a[4002][4],sum1[16000002],sum2[16000002];
int main()
{
int n,mid;
while(~scanf("%d",&n))
{
for(int i=0; i<n; i++)
{
scanf("%d%d%d%d",&a[i][0],&a[i][1], &a[i][2],&a[i][3]);
}
int k=0;
int m=0;
for(int i=0; i<n; i++)
for(int j=0; j<n; j++)
{
sum1[k++]=a[i][0]+a[j][1];
sum2[m++]=a[i][2]+a[j][3];
}
sort(sum2,sum2+k);
int cnt=0;
for(int i=0; i<k; i++)
{
int left=0;
int right=k-1;
while(left<=right)
{
mid=(left+right)/2;
if(sum1[i]+sum2[mid]==0)
{
cnt++;
for(int j=mid+1;j<k;j++)
{
if(sum1[i]+sum2[j]!=0)
break;
else
cnt++;
}
for(int j=mid-1;j>=0;j--)
{
if(sum1[i]+sum2[j]!=0)
break;
else
cnt++;
}
break;
}
if(sum1[i]+sum2[mid]<0)
left=mid+1;
else
right=mid-1;
}
}
printf("%d\n",cnt);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: