您的位置:首页 > 其它

题目1170:找最小数

2014-02-21 20:23 120 查看
题目描述:
第一行输入一个数n,1 <= n <= 1000,下面输入n行数据,每一行有两个数,分别是x y。输出一组x y,该组数据是所有数据中x最小,且在x相等的情况下y最小的。 

输入:
输入有多组数据。

每组输入n,然后输入n个整数对。

输出:
输出最小的整数对。

样例输入:
5
3 3
2 2
5 5
2 1
3 6

样例输出:
2 1


import java.io.IOException;
import java.io.FileReader;
import java.io.InputStreamReader;
import java.io.BufferedReader;
import java.util.Scanner;
import java.lang.Comparable;
import java.util.Arrays;

class Point implements Comparable<Point>
{
public int x, y;

public Point(int x, int y)
{
this.x = x;
this.y = y;
}

public int compareTo(Point other)
{
if (x != other.x) return x - other.x;

return y - other.y;
}
}

class Main
{
public static final boolean DEBUG = false;

public static void main(String[] args) throws IOException
{
Scanner cin;
int n;

if (DEBUG) {
cin = new Scanner(new FileReader("d:\\OJ\\uva_in.txt"));
} else {
cin = new Scanner(new InputStreamReader(System.in));
}

while (cin.hasNext()) {
n = cin.nextInt();
Point[] p = new Point
;

for (int i = 0; i < n; i++) {
int x = cin.nextInt();
int y = cin.nextInt();
p[i] = new Point(x, y);
}

Arrays.sort(p);

System.out.println(p[0].x + " " + p[0].y);
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: