您的位置:首页 > 编程语言 > C语言/C++

山东理工大学ACM平台题答案关于C语言 1543 Egypt

2013-12-18 20:38 211 查看

Egypt


Time Limit: 1000ms Memory limit: 65536K 有疑问?点这里^_^

题目描述

A long time ago, the Egyptians figured out that a triangle with sides of length 3, 4, and 5 had a right angle as its largest angle. You must determine if other triangles have a similar property.



输入

Input represents several test cases, followed by a line containing 0 0 0. Each test case has three positive integers, less than 30,000, denoting the lengths of the sides of a triangle.

输出

For each test case, a line containing "right" if the triangle is a right triangle, and a line containing "wrong" if the triangle is not a right triangle.

示例输入

6 8 10
25 52 60
5 12 13
0 0 0


示例输出

right
wrong
right


#include<stdio.h>

void main()

{

int a,b,c,temp;

while(scanf("%d %d %d",&a,&b,&c),a||b||c)//abc同时wei0的时候结束

{

if(a>b)

{

temp=a;

a=b;

b=temp;

}

if(a>c)

{

temp=a;

a=c;

c=temp;

}

if(b>c)

{

temp=b;

b=c;

c=temp;

}

if(a*a+b*b==c*c)

printf("right\n");

else

printf("wrong\n");

}

}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐