您的位置:首页 > 编程语言 > C语言/C++

山东理工大学ACM平台题答案关于C语言 1259 Bad Hair Day

2013-12-14 16:03 323 查看

Bad Hair Day


Time Limit: 2000ms Memory limit: 65536K 有疑问?点这里^_^

题目描述

Some of Farmer John's N cows (1 ≤ N ≤ 80,000) are having a bad hair day! Since each cow is self-conscious about her messy hairstyle, FJ wants to count the number of other cows that can see the top of other cows' heads.

Each cow i has a specified height hi (1 ≤ hi ≤ 1,000,000,000) and is standing in a line of cows all facing east (to the right in our diagrams). Therefore, cow i can see the tops of the heads of cows in front of her (namely cows i+1, i+2, and so on), for as
long as these cows are strictly shorter than cow i.

Consider this example:

        =

=       =

=   =   =       Cows facing right-->

=   =   =

= = = = =

= = = = = =

1 2 3 4 5 6

Cow#1 can see the hairstyle of cows #2, 3, 4

Cow#2 can see no cow's hairstyle

Cow#3 can see the hairstyle of cow #4

Cow#4 can see no cow's hairstyle

Cow#5 can see the hairstyle of cow 6

Cow#6 can see no cows at all!

Let ci denote the number of cows whose hairstyle is visible from cow i; please compute the sum of c1 through cN.For this example, the desired is answer 3 + 0 + 1 + 0 + 1 + 0 = 5.

输入

Line 1: The number of cows, N.

Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i.

输出

Line 1: A single integer that is the sum of c1 through cN.

示例输入

6
10
3
7
4
12
2


示例输出

5

Bad Hair Day倒霉的日子Time Limit: 2000ms Memory limit: 65536K 有疑问?点这里^_^时间限制:2000ms内存限制:65536k有疑问点这里^ _ ^?题目描述题目描述Some of Farmer John's N cows (1 ≤ N ≤ 80,000) are having a bad hair day! Since each cow is self-conscious about her messy hairstyle, FJ wants to count the number of other cows that can see the top of other cows' heads.一些农夫约翰的奶牛(1≤N≤80000)有一个糟糕的发型!由于每个奶牛对她凌乱的发型的自觉,福建要清点人数,其他的奶牛,可以看到其他牛的头上。Each cow i has a specified height hi (1 ≤ hi ≤ 1,000,000,000) and is standing in a line of cows all facing east (to the right in our diagrams). Therefore, cow i can see the tops of the heads of cows in front of her (namely cows i+1, i+2, and so on), for as long as these cows are strictly shorter than cow i. 我有一个指定的每头奶牛的高度高(1≤嗨≤1000000000)和站立在一行牛所有面向东方(在图右)。因此,我可以看到牛在她面前的奶牛的头的顶端(即牛,我1,我2,等等),只要这些牛是严格小于牛岛Consider this example:考虑一下这个例子:        ===       ====   =   =       Cows facing right-->===牛朝右-->=   =   ===== = = = ======= = = = = =======1 2 3 4 5 61 2 3 4 5 6Cow#1 can see the hairstyle of cows #2, 3, 4牛# 1可以看到牛# 2,3型,4Cow#2 can see no cow's hairstyle牛# 2可以看到没有牛的发型Cow#3 can see the hairstyle of cow #4牛# 3可以看到牛# 4发型Cow#4 can see no cow's hairstyle 牛# 4可以看到没有牛的发型Cow#5 can see the hairstyle of cow 6牛# 5可以看到牛6头发型Cow#6 can see no cows at all! 牛# 6可以看到牛都没有!Let ci denote the number of cows whose hairstyle is visible from cow i; please compute the sum of c1 through cN.For this example, the desired is answer 3 + 0 + 1 + 0 + 1 + 0 = 5.让词表示的奶牛的发型是从牛我可见的数量;请通过CN计算C1的总和。在这个例子中,所需的回答“3 + 0 + 1 + 0 + 1 + 0 = 5。输入输入Line 1: The number of cows, N. 行1:牛的数量,N。Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i.线2。n + 1 + 1:我行包含一个整数,牛岛的高度输出输出Line 1: A single integer that is the sum of c1 through cN.1行:一个整数,即通过CN C1的总和。示例输入示例输入66101033774412122示例输出2示例输出55

#include <stdio.h>

int main()

{

int n, i, j, count;

int a[80000];

while (scanf("%d", &n) == 1){

for (i=0; i<n; i++)

scanf("%d", a+i);

count = 0;

for (i=0; i<n; i++){

for (j=i+1; j<n; j++)

if (a[j] >= a[i]) break;

count += j-i-1;

}

printf("%d\n", count);

}

return 0;

}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐