您的位置:首页 > 编程语言 > C语言/C++

山东理工大学ACM平台题答案关于C语言 1048 Digital Roots

2013-12-15 15:55 387 查看

Digital Roots

数字的根


Time Limit: 1000ms Memory limit: 65536K 有疑问?点这里^_^

题目描述

The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed
and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process
must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

输入

The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.

输出

For each integer in the input, output its digital root on a separate line of the output.

示例输入

24
39
0


示例输出

6
3


提示

请注意,输入数据长度不超过20位数字。


#include <stdio.h>

#include <string.h>

int getNRoot(int n)

{

if (n < 10) return n;

int r = 0;

while (n){

r += n%10;

n /= 10;

}

return getNRoot(r);

}

int getSRoot(char s[])

{

int i, r = 0;

for (i=strlen(s)-1; i>=0; i--)

r += (s[i]-'0');

return getNRoot(r);

}

int main()

{

char s[1001];

while (scanf("%s", s)==1){

if (strlen(s)==1 && s[0]=='0') break;

printf("%d\n", getSRoot(s));

}

return 0;

}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐