您的位置:首页 > 其它

UVA 557 - Burger(概率 递推)

2013-11-21 20:31 387 查看


 Burger 
When Mr. and Mrs. Clinton's twin sons Ben and Bill had their tenth birthday, the party was held at the McDonald's restaurant at South Broadway 202, New York. There were 20 kids at the party, including
Ben and Bill. Ronald McDonald had made 10 hamburgers and 10 cheeseburgers and when he served the kids he started with the girl directly sitting left of Bill. Ben was sitting to the right of Bill. Ronald flipped a (fair) coin to decide if the girl should have
a hamburger or a cheeseburger, head for hamburger, tail for cheeseburger. He repeated this procedure with all the other 17 kids before serving Ben and Bill last. Though, when coming to Ben he didn't have to flip the coin anymore because there were no cheeseburgers
left, only 2 hamburgers.

Ronald McDonald was quite surprised this happened, so he would like to know what the probability is of this kind of events. Calculate the probability that Ben and Bill will get the same type of burger using the procedure described above. Ronald McDonald always
grills the same number of hamburgers and cheeseburgers.

Input 

The first line of the input-file contains the number of problems n ,
followed by n times:

a line with an even number [2,4,6,...,100000], which indicates the number of guests present at the party including Ben and Bill.

Output 

The output consists of n lines with on each line the probability
(4 decimals precise) that Ben and Bill get the same type of burger.

Note: a variance of 

 is allowed in the output due to rounding differences.

Sample Input 

3
6
10
256


Sample Output 

0.6250
0.7266
0.9500

题意:给定2n个人,有n个汉堡和n个 奶酪汉堡,Ben and Bill排在最后,然后抛硬币,正反面分别拿汉堡和奶酪汉堡,如果有一样拿完了就不需要在扔硬币了。求最后ben和bill拿到一样的概率。

思路:由于有如果有一样拿完了就不需要在扔硬币了这个条件,我们就反过来推,如果ben和bill拿的不一样,那么硬币肯定要扔到最后,那么也就是说,过程中每个人都要经过人硬币,所以我们求这个概率p,然后1-p即可,公式为C(2n - 2,
n -1) * 2 ^ (2n - 2). 但是n有十万,直接求肯定不行,进行递推, p[i+1] / p[i]得到一个式子P[i + 1] = p[i] * (1 - 0.5 / i);

代码:

#include <stdio.h>
#include <string.h>
const int N = 50005;

int t, n;
double p
;

void init() {
p[1] = 1.0;
for (int i = 1; i <= 50000; i ++)
p[i + 1] = p[i] * (1 - 0.5 / i);
}

int main() {
init();
scanf("%d", &t);
while (t --) {
scanf("%d", &n);
printf("%.4lf\n", 1 - p[n / 2]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: