您的位置:首页 > 其它

POJ 1459 Power Network【最大流基础题 EK 算法】

2013-11-16 16:07 344 查看

题目:http://poj.org/problem?id=1459

Power Network

Time Limit: 2000MSMemory Limit: 32768K
Total Submissions: 21305Accepted: 11165
Description
A power network consists of nodes (power stations, consumers and dispatchers) connected by power transport lines. A node u may be supplied with an amount s(u) >= 0 of power, may
produce an amount 0 <= p(u) <= pmax(u) of power, may consume an amount 0 <= c(u) <= min(s(u),cmax(u)) of power, and may deliver an amount d(u)=s(u)+p(u)-c(u) of power. The following restrictions apply: c(u)=0 for any power station, p(u)=0
for any consumer, and p(u)=c(u)=0 for any dispatcher. There is at most one power transport line (u,v) from a node u to a node v in the net; it transports an amount 0 <= l(u,v) <= lmax(u,v) of power delivered by u to v. Let Con=Σuc(u)
be the power consumed in the net. The problem is to compute the maximum value of Con. 



An example is in figure 1. The label x/y of power station u shows that p(u)=x and pmax(u)=y. The label x/y of consumer u shows that c(u)=x and cmax(u)=y. The label x/y of power transport line (u,v) shows that l(u,v)=x and lmax(u,v)=y.
The power consumed is Con=6. Notice that there are other possible states of the network but the value of Con cannot exceed 6. 

Input
There are several data sets in the input. Each data set encodes a power network. It starts with four integers: 0 <= n <= 100 (nodes), 0 <= np <= n (power stations), 0 <= nc <= n
(consumers), and 0 <= m <= n^2 (power transport lines). Follow m data triplets (u,v)z, where u and v are node identifiers (starting from 0) and 0 <= z <= 1000 is the value of lmax(u,v). Follow np doublets (u)z, where u is the identifier of a power
station and 0 <= z <= 10000 is the value of pmax(u). The data set ends with nc doublets (u)z, where u is the identifier of a consumer and 0 <= z <= 10000 is the value of cmax(u). All input numbers are integers. Except the (u,v)z triplets
and the (u)z doublets, which do not contain white spaces, white spaces can occur freely in input. Input data terminate with an end of file and are correct.
Output
For each data set from the input, the program prints on the standard output the maximum amount of power that can be consumed in the corresponding network. Each result has an integral
value and is printed from the beginning of a separate line.
Sample Input
2 1 1 2 (0,1)20 (1,0)10 (0)15 (1)20
7 2 3 13 (0,0)1 (0,1)2 (0,2)5 (1,0)1 (1,2)8 (2,3)1 (2,4)7
(3,5)2 (3,6)5 (4,2)7 (4,3)5 (4,5)1 (6,0)5
(0)5 (1)2 (3)2 (4)1 (5)4

Sample Output
15
6

Hint
The sample input contains two data sets. The first data set encodes a network with 2 nodes, power station 0 with pmax(0)=15 and consumer 1 with cmax(1)=20, and 2 power transport
lines with lmax(0,1)=20 and lmax(1,0)=10. The maximum value of Con is 15. The second data set encodes the network from figure 1.
Source
Southeastern Europe 2003

/**
题意:
电力网中有 n 个节点
np 个发电站
nc 个消费者
m 条线路

有且仅有发电站能产生电
有且仅有消费者会消耗电

任意两点之间最多只有一条线路存在

求网络中的最大电力消耗

输入:
先是输入四个整数 n,np,nc,m
然后再输入 m 个(u,v)w 形式的三元组,表示 u 到 v 传输 w 能量的电
再就是输入 np 个(u)w 形式的二元组, 表示发电站 u 能产生 w 能量的电
最后是 nc 个 (u)w 形式的二元组, 表示消费者 u 消耗 w 能量的电

建立模型:
设置一个超级源点:使得所有的发电站与其相连
设置一个超级汇点:使得所有的消费者与其相连
这样就变成了普通的最大流问题

参考资料:
ACM-ICPC 程序设计系列 图论及应用
算法竞赛入门经典
**/
#include<stdio.h>
#include<string.h>
#include<queue>
#include<iostream>
using namespace std;

const int maxn = 105;
const int INF = 99999999;

int cap[maxn][maxn];
int flow[maxn][maxn];
int a[maxn];
int pre[maxn];

int n,np,nc,m;

int EK(int start, int end)
{
memset(flow,0,sizeof(flow));
int f = 0;
queue<int> q;
while(!q.empty()) q.pop();

for(;;)
{
memset(a,0,sizeof(a));
a[start] = INF;
q.push(start);

while(!q.empty())
{
int u = q.front(); q.pop();
for(int v = 1; v <= n+1; v++)
{
if(!a[v] && cap[u][v]>flow[u][v])
{
pre[v] = u;
q.push(v);
a[v] = min(a[u], cap[u][v]-flow[u][v]);
}
}
}

if(a[end] == 0) break;
f += a[end];

for(int u = end; u != start; u = pre[u])
{
flow[pre[u]][u] += a[end];
flow[u][pre[u]] -= a[end];
}
}
return f;
}
int main()
{
while(cin>>n>>np>>nc>>m)
{
memset(cap,0,sizeof(cap));
char c;
int u,v,w;
while(m--)
{
cin>>c>>u>>c>>v>>c>>w;
cap[u+1][v+1] = w;
}

while(np--)
{
cin>>c>>u>>c>>w;
cap[0][u+1] = w;
}

while(nc--)
{
cin>>c>>u>>c>>w;
cap[u+1][n+1] = w;
}

int ans = EK(0,n+1);
printf("%d\n", ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: