您的位置:首页 > 理论基础 > 计算机网络

poj-1459 Power Network(网络最大流问题)

2014-08-10 16:10 309 查看
Power Network

Time Limit:2000MS Memory Limit:32768KB
Description

A power network consists of nodes (power stations, consumers and dispatchers) connected by power transport lines. A node u may be supplied with an amount s(u) >= 0 of power, may produce an amount 0 <= p(u) <= pmax(u) of power, may consume an amount 0 <= c(u)
<= min(s(u),cmax(u)) of power, and may deliver an amount d(u)=s(u)+p(u)-c(u) of power. The following restrictions apply: c(u)=0 for any power station, p(u)=0 for any consumer, and p(u)=c(u)=0 for any dispatcher. There is at most one power transport line (u,v)
from a node u to a node v in the net; it transports an amount 0 <= l(u,v) <= lmax(u,v) of power delivered by u to v. Let Con=Σuc(u) be the power consumed in the net. The problem is to compute the maximum value of Con.




An example is in figure 1. The label x/y of power station u shows that p(u)=x and pmax(u)=y. The label x/y of consumer u shows that c(u)=x and cmax(u)=y. The label x/y of power transport line (u,v) shows that l(u,v)=x and lmax(u,v)=y. The power consumed is
Con=6. Notice that there are other possible states of the network but the value of Con cannot exceed 6.

Input

There are several data sets in the input. Each data set encodes a power network. It starts with four integers: 0 <= n <= 100 (nodes), 0 <= np <= n (power stations), 0 <= nc <= n (consumers), and 0 <= m <= n^2 (power transport lines). Follow m data triplets
(u,v)z, where u and v are node identifiers (starting from 0) and 0 <= z <= 1000 is the value of lmax(u,v). Follow np doublets (u)z, where u is the identifier of a power station and 0 <= z <= 10000 is the value of pmax(u). The data set ends with nc doublets
(u)z, where u is the identifier of a consumer and 0 <= z <= 10000 is the value of cmax(u). All input numbers are integers. Except the (u,v)z triplets and the (u)z doublets, which do not contain white spaces, white spaces can occur freely in input. Input data
terminate with an end of file and are correct.

Output

For each data set from the input, the program prints on the standard output the maximum amount of power that can be consumed in the corresponding network. Each result has an integral value and is printed from the beginning of a separate line.

Sample Input

2 1 1 2 (0,1)20 (1,0)10 (0)15 (1)20

7 2 3 13 (0,0)1 (0,1)2 (0,2)5 (1,0)1 (1,2)8 (2,3)1 (2,4)7

(3,5)2 (3,6)5 (4,2)7 (4,3)5 (4,5)1 (6,0)5

(0)5 (1)2 (3)2 (4)1 (5)4

Sample Output

15

6

最大流算法模板:/article/1969749.html

给出有发电站,变电站,用电场所三种的关系,求最大用电量。

可以采用网络流模型来解决:在原图的基础上添加源点st和汇点ed。对每个发电站,从源点引一条容量为p(最大发电量)的弧,对每个用电场所,引一条容量为c(最大用电量)的弧到汇点,对每个(u,v,z)输入,从点u引一条容量为z的弧到点v。便构成了一个从st到ed的求网络最大流的问题,套用模板即可。

//Memory 252 KB  Time 407 ms
#include<iostream>
#include<string.h>
#include<queue>
#include<stdio.h>
using namespace std;
#define N 102
int n;
int c

;
int a
,f

,p
;
int MaxFlow(int st,int ed)
{
	int u,v;
	queue<int> que;
	memset(f,0,sizeof(f));
	int mf=0;
	while(1)
	{
		memset(a,0,sizeof(a));
		a[st]=0x3f3f3f3f;
		que.push(st);
		while(!que.empty())
		{
			u=que.front();
			que.pop();
			for(v=0;v<=n+1;v++)
				if(!a[v]&&f[u][v]<c[u][v])
				{
					p[v]=u;que.push(v);
					a[v]=a[u]<c[u][v]-f[u][v]?a[u]:c[u][v]-f[u][v];
				}
		}
		if(!a[ed]) break;
		for(v=ed;v!=st;v=p[v])
		{
			f[p[v]][v]+=a[ed];
			f[v][p[v]]-=a[ed];
		}
		mf+=a[ed];
	}
	return mf;
}
int main()
{
	int st,ed;
	int ans,np,nc,m,i,u,v,z;
	char s1[3],s2[3];
	while(scanf("%d%d%d%d",&n,&np,&nc,&m)!=EOF)
	{
		st=n;ed=n+1;
		memset(c,0,sizeof(c));
		for(i=1;i<=m;i++)
		{
			scanf("%1s%d%,%d%1s%d",s1,&u,&v,s2,&z);
			c[u][v]=z;
		}
		for(i=1;i<=np;i++)
		{
			scanf("%1s%d%1s%d",s1,&u,s2,&z);
			c[st][u]=z;
		}
		for(i=1;i<=nc;i++)
		{
			scanf("%1s%d%1s%d",s1,&u,s2,&z);
			c[u][ed]=z;
		}
		ans=MaxFlow(st,ed);
		printf("%d\n",ans);
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: