您的位置:首页 > 其它

【PAT】1029. Median (25)

2013-10-30 10:13 281 查看
Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1={11, 12, 13, 14} is 12, and the median of S2={9, 10, 15, 16, 17} is 15. The median of two sequences is defined to be the
median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

Given two increasing sequences of integers, you are asked to find their median.

Input

Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (<=1000000) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed
that all the integers are in the range of long int.

Output

For each test case you should output the median of the two given sequences in a line.

Sample Input
4 11 12 13 14
5 9 10 15 16 17

Sample Output
13


分析:寻找中位数。一开始用sort来进行排序后找出中位数,但是这样会有两组数据超时。所以只能进行逐一比较。

代码:

#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
int main()
{
int n;
long t;
int i;

scanf("%d",&n);
vector<long> vec1(n);
for(i=0; i<n; i++)
scanf("%ld",&vec1[i]);

scanf("%d",&n);
vector<long> vec2(n);
for(i=0; i<n; i++)
scanf("%ld",&vec2[i]);

int j,temp = 0;
long v;
vector<long> result;

for(i=0,j=0; i<vec1.size() && j<vec2.size(); )
{
if(vec1[i] <= vec2[j]){
v = vec1[i];
i++;
}
else{
v = vec2[j];
j++;
}
result.push_back(v);
if(result.size() == ( vec1.size() + vec2.size() + 1)/2 ){
cout<<result[result.size() - 1]<<endl;
break;
}
}

if(result.size() != ( vec1.size() + vec2.size() + 1)/2)
{
while(i<vec1.size())
{
result.push_back(vec1[i]);
if(result.size() == ( vec1.size() + vec2.size() + 1)/2 ){
cout<<result[result.size() - 1]<<endl;
break;
}
i++;
}
while(j<vec2.size())
{
result.push_back(vec2[j]);
if(result.size() == ( vec1.size() + vec2.size() + 1)/2 ){
cout<<result[result.size() - 1]<<endl;
break;
}
j++;
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  PAT