您的位置:首页 > 其它

hdu 1102(最小生成树)

2013-09-11 14:06 302 查看

Constructing Roads

Time
Limit: 2000/1000 MS
(Java/Others)    Memory
Limit: 65536/32768 K (Java/Others)Total Submission(s):
5227    Accepted
Submission(s): 1896
Problem DescriptionThere are N villages, which are numbered from 1 to N, and you
should build some roads such that every two villages can connect to
each other. We say two village A and B are connected, if and only
if there is a road between A and B, or there exists a village C
such that there is a road between A and C, and C and B are
connected. We know that there are already some roads between some villages and
your job is the build some roads such that all the villages are
connect and the length of all the roads built is
minimum. InputThe first line is an integer N (3 <= N
<= 100), which is the number of villages. Then come
N lines, the i-th of which contains N integers, and the j-th of
these N integers is the distance (the distance should be an integer
within [1, 1000]) between village i and village j.Then there is an integer Q (0 <= Q <=
N * (N + 1) / 2). Then come Q lines, each line contains two
integers a and b (1 <= a < b
<= N), which means the road between village a and
village b has been built. OutputYou should output a line contains an integer, which is the length
of all the roads to be built such that all the villages are
connected, and this value is minimum.  Sample Input

3 0
990 692 990 0 179 692 179 0 1 1 2 Sample Output
179 #include<stdio.h>
#define MAX
1000000
int
map[105][105];
int
lowcost[105];
int
N;
void Prim(int
map[][105],int n)
{
  
 int i,j,k,road=0;
  
 int min;
  
 for(i=2;i<=N;i++)
    
     
 lowcost[i]=map[1][i];
    
 
 for(i=2;i<=N;i++)
    
   {
    
     
 min=lowcost[i];
    
     
 k=i;
    
     
 for(j=2;j<=N;j++)
    
     
   
 if(min>lowcost[j])
    
     
   
 {
    
     
     
   min=lowcost[j];
    
     
     
   k=j;
    
     
   
 }
    
     
 road+=min;
    
     
 lowcost[k]=MAX;
    
     
 for(j=2;j<=N;j++)
    
     
 {
    
     
   
 if((map[k][j]<lowcost[j])&&(lowcost[j]<MAX))
    
     
   
 {
    
     
     
 
 lowcost[j]=map[k][j];
    
     
   
 }
    
     
 }
    
   }
    
 
 printf("%d\n",road);
}
int
main()
{
   
  
 int n,i,j;
  
 while(scanf("%d",&N)!=EOF)
  
 {
    
   
    
 
 for(i=1;i<=N;i++)
    
     
 for(j=1;j<=N;j++)
    
     
   
 scanf("%d",&map[i][j]);
    
 
 scanf("%d",&n);
    
   while(n--)
    
   {
    
     
 scanf("%d%d",&i,&j);
    
     
 map[i][j]=map[j][i]=0;
    
     
 
    
   }
    
   Prim(map,N);
    
   
  
 }
  
 return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: