您的位置:首页 > 其它

UVA 10382 Watering Grass (贪心 + 区间覆盖问题)

2013-08-17 20:07 671 查看
Problem E

Watering Grass

Input:
 standard input
Output: standard output
Time Limit: 3 seconds

n sprinklers are installed in a horizontal strip of grass l meters long and w meters wide. Each sprinkler is installed at the horizontal center line of the strip. For each sprinkler we are given its position as the distance from
the left end of the center line and its radius of operation.

What is the minimum number of sprinklers to turn on in order to water the entire strip of grass?



Input

Input consists of a number of cases. The first line for each case contains integer numbers n, l and w with n <= 10000. The next n lines contain two integers giving the position of a sprinkler and its radius of
operation. (The picture above illustrates the first case from the sample input.)

 

Output

For each test case output the minimum number of sprinklers needed to water the entire strip of grass. If it is impossible to water the entire strip output -1.

Sample input

8 20 2

5 3

4 1

1 2

7 2

10 2

13 3

16 2

19 4

3 10 1

3 5

9 3

6 1

3 10 1

5 3

1 1

9 1

 

Sample Output

6

2

-1

题意:给定一条草坪。草坪上有n个喷水装置。草坪长l米宽w米。。n个装置都有每个装置的位置和喷水半径。。要求出最少需要几个喷水装置才能喷满草坪。。喷水装置都是装在草坪中间一条水平线上的。。
思路;区间覆盖问题。用贪心。按覆盖最远的排序。。每次找最远的然后更行左边界。。

不过这题有个要注意的地方是圆的话。最远覆盖点要去进行计算。为和草坪上下边交点为最远。根据勾股定理很容易算出

代码:

#include <stdio.h>
#include <string.h>
#include <math.h>
#include <algorithm>
using namespace std;

int n;
double l, w;
double v, r;
int num;
struct O {
double l, r;
} yuan[10005];

int cmp(O a, O b) {
return a.r > b.r;
}
int main() {
while (~scanf("%d%lf%lf", &n, &l, &w)) {
double go = 0;
num = 0;
for (int i = 0; i < n; i ++) {
scanf("%lf%lf", &v, &r);
yuan[i].l = v - sqrt(r * r - w * w / 4);//计算右覆盖最远距离
yuan[i].r = v + sqrt(r * r - w * w / 4);//计算左覆盖最远距离
}
sort(yuan, yuan + n, cmp);
while (go < l) {
int i;
for (i = 0; i < n; i ++) {
if (yuan[i].l <= go && yuan[i].r > go) {
go = yuan[i].r;//更新区间左端。
num ++;
break;
}
}
if (i == n)
break;
}
if (go < l) printf("-1\n");
else printf("%d\n", num);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: