您的位置:首页 > 其它

UVA 108 Maximum Sum(子矩阵最大和)

2013-08-18 10:17 344 查看


 Maximum Sum 

Background

A problem that is simple to solve in one dimension is often much more difficult to solve in more than one dimension. Consider satisfying a boolean expression in conjunctive normal form in which each conjunct
consists of exactly 3 disjuncts. This problem (3-SAT) is NP-complete. The problem 2-SAT is solved quite efficiently, however. In contrast, some problems belong to the same complexity class regardless of the dimensionality of the problem.

The Problem

Given a 2-dimensional array of positive and negative integers, find the sub-rectangle with the largest sum. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the
sub-rectangle with the largest sum is referred to as the maximal sub-rectangle. A sub-rectangle is any contiguous sub-array of size 

 or
greater located within the whole array. As an example, the maximal sub-rectangle of the array:



is in the lower-left-hand corner:



and has the sum of 15.

Input and Output

The input consists of an 

 array of integers. The input begins with a single
positive integer N on a line by itself indicating the size of the square two dimensional array. This is followed by 

 integers
separated by white-space (newlines and spaces). These 

 integers make up the array in row-major order (i.e., all numbers on the first
row, left-to-right, then all numbers on the second row, left-to-right, etc.). N may be as large as 100. The numbers in the array will be in the range [-127, 127].

The output is the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7  0 9  2 -6  2
-4  1 -4  1 -1
8  0 -2


Sample Output

15

题意:给定一个矩阵。要求出一个和最大的子矩阵之和。。

思路:和一维的求最大和子序列有点类似。不过这是二维的。直接暴力会超时。所以每次进行操作的时候。要把值保留下来。以备给后面使用。这样可以大大减少所用的时间。。

代码:

#include <stdio.h>
#include <string.h>
#include <limits.h>
int n, num[105][105], Max, he, sum[105];

void init() {
Max = -INT_MAX;
for (int i = 0; i < n ; i ++)
for (int j = 0 ; j < n ; j ++)
scanf("%d", &num[i][j]);
}

int solve() {
for (int i = 0; i < n ; i ++) {
memset(sum, 0, sizeof(sum));
for (int j = i; j < n; j ++) {
he = 0;
for (int k = 0; k < n; k ++) {
sum[k] += num[j][k];
if (he >= 0)//这步跟求最大子序列和一个原理。。如果加到是负数的时候,是会使总和减少的。所以直接从下一个位置开始作为起点。
he += sum[k];
else
he = sum[k];
if (Max < he)
Max = he;
}
}
}
return Max;
}

int main() {
while (~scanf("%d", &n)) {
init();
printf("%d\n", solve());
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: