您的位置:首页 > 其它

UVa120 Stacks of Flapjacks

2015-07-08 12:51 357 查看
Description

Background

Stacks and Queues are often considered the bread and butter of data structures and find use in architecture, parsing, operating systems, and discrete event simulation. Stacks are also important in the theory
of formal languages.
This problem involves both butter and sustenance in the form of pancakes rather than bread in addition to a finicky server who flips pancakes according to a unique, but complete set of rules.

The Problem

Given a stack of pancakes, you are to write a program that indicates how the stack can be sorted so that the largest pancake is on the bottom and the smallest pancake is on the top. The size of a pancake is
given by the pancake's diameter. All pancakes in a stack have different diameters.
Sorting a stack is done by a sequence of pancake ``flips''. A flip consists of inserting a spatula between two pancakes in a stack and flipping (reversing) the pancakes on the spatula (reversing the sub-stack).
A flip is specified by giving the position of the pancake on the bottom of the sub-stack to be flipped (relative to the whole stack). The pancake on the bottom of the whole stack has position 1 and the pancake on the top of a stack of n pancakes has
position n.
A stack is specified by giving the diameter of each pancake in the stack in the order in which the pancakes appear.
For example, consider the three stacks of pancakes below (in which pancake 8 is the top-most pancake of the left stack):
8           7           2
4           6           5
6           4           8
7           8           4
5           5           6
2           2           7

The stack on the left can be transformed to the stack in the middle via flip(3). The middle stack can be transformed into the right stack via the command flip(1).

The Input

The input consists of a sequence of stacks of pancakes. Each stack will consist of between 1 and 30 pancakes and each pancake will have an integer diameter between 1 and 100. The input is terminated by end-of-file.
Each stack is given as a single line of input with the top pancake on a stack appearing first on a line, the bottom pancake appearing last, and all pancakes separated by a space.

The Output

For each stack of pancakes, the output should echo the original stack on one line, followed by some sequence of flips that results in the stack of pancakes being sorted so that the largest diameter pancake is
on the bottom and the smallest on top. For each stack the sequence of flips should be terminated by a 0 (indicating no more flips necessary). Once a stack is sorted, no more flips should be made.

Sample Input

1 2 3 4 5
5 4 3 2 1
5 1 2 3 4


Sample Output

1 2 3 4 5
0
5 4 3 2 1
1 0
5 1 2 3 4
1 2 0


分析样例:

2 4 1 5 3

标记堆底元素,找到3上方且包括3的这些元素中的最大值5。5不在堆顶,将5翻转到堆顶,输出翻转的起始位置,由堆底往上数,输出2:

5 1 4 2 3

将最大值翻转到标记位置,输出1:

3 2 4 1 5

标记上移一位,标记1的位置,找到1上面包括1的元素中的最大值4。4不在堆顶,将4翻转到堆顶,输出3:

4 2 3 1 5

将最大值翻转到标记位置,输出2:

1 3 2 4 5

标记继续上移一位,标记2的位置,找到最大值3,将3翻转到堆顶,输出4:

3 1 2 4 5

将最大值翻转到标记位置,输出3:

2 1 3 4 5

标记上移一位,标记1的位置,找到最大值2,2在堆顶,将2翻转到标记位置,输出4:

1 2 3 4 5

翻转完成,输出0.最后输出结果:

2 1 3 2 4 3 4 0

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <sstream>
#include <deque>
using namespace std;
const int MAXN = 70;

char str[MAXN];
deque<int> d;
deque<int>::iterator it,maxn;

int main(){
//freopen("test.in","rt",stdin);
int n;
while(fgets(str,MAXN,stdin)){ //按行输入,并存如str数组中
cout <<str;
//istringstream对象绑定一行字符串,然后以空格为分隔符把该行分隔开来。
istringstream s(str);
d.clear();
//将istringstream对象中的元素转为int型并存入变量n中,入队
while(s >>n){
d.push_front(n);
}
for(it= d.begin();it != d.end();++it){
maxn = max_element(it,d.end()); //找到当前位置到堆顶的最大元素
if(maxn != it){ //最大元素不是i,进行翻转
if(maxn != d.end() -1){ //最大元素不在堆顶,则需要翻转到堆顶
reverse(maxn,d.end()); //将最大值翻转到堆顶
cout <<maxn-d.begin() + 1 <<" ";
}
reverse(it,d.end()); //将最大值翻转到需要定位的位置
cout <<it - d.begin() + 1 <<" ";
}
}
cout <<"0" <<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: