您的位置:首页 > 其它

uva 400 Unix ls(借助printf("%*s",int, char*);控制格式)

2013-07-20 20:39 423 查看


 Unix ls 
The computer company you work for is introducing a brand new computer line and is developing a new Unix-like operating system to be introduced along with the new computer. Your assignment is to write the formatter for the ls function.

Your program will eventually read input from a pipe (although for now your program will read from the input file). Input to your program will consist of a list of (F) filenames that you will sort (ascending based on the ASCII character values) and
format into (C) columns based on the length (L) of the longest filename. Filenames will be between 1 and 60 (inclusive) characters in length and will be formatted into left-justified columns. The rightmost column will be the width of the
longest filename and all other columns will be the width of the longest filename plus 2. There will be as many columns as will fit in 60 characters. Your program should use as few rows (R) as possible with rows being filled to capacity from left to
right.


Input

The input file will contain an indefinite number of lists of filenames. Each list will begin with a line containing a single integer ( 

 ).
There will then be N lines each containing one left-justified filename and the entire line's contents (between 1 and 60 characters) are considered to be part of the filename. Allowable characters are alphanumeric (a to z, A to Z,
and 0 to 9) and from the following set 
{ ._- }
 (not including the curly braces). There will be no illegal characters in any of the filenames and no line will be completely empty.

Immediately following the last filename will be the N for the next set or the end of file. You should read and format all sets in the input file.


Output

For each set of filenames you should print a line of exactly 60 dashes (-) followed by the formatted columns of filenames. The sorted filenames 1 to R will be listed down column 1; filenames R+1 to 2R listed down column 2;
etc.


Sample Input

10
tiny
2short4me
very_long_file_name
shorter
size-1
size2
size3
much_longer_name
12345678.123
mid_size_name
12
Weaser
Alfalfa
Stimey
Buckwheat
Porky
Joe
Darla
Cotton
Butch
Froggy
Mrs_Crabapple
P.D.
19
Mr._French
Jody
Buffy
Sissy
Keith
Danny
Lori
Chris
Shirley
Marsha
Jan
Cindy
Carol
Mike
Greg
Peter
Bobby
Alice
Ruben



Sample Output

------------------------------------------------------------
12345678.123         size-1
2short4me            size2
mid_size_name        size3
much_longer_name     tiny
shorter              very_long_file_name
------------------------------------------------------------
Alfalfa        Cotton         Joe            Porky
Buckwheat      Darla          Mrs_Crabapple  Stimey
Butch          Froggy         P.D.           Weaser
------------------------------------------------------------
Alice       Chris       Jan         Marsha      Ruben
Bobby       Cindy       Jody        Mike        Shirley
Buffy       Danny       Keith       Mr._French  Sissy
Carol       Greg        Lori        Peter

题目大意:给出n个字符串,在宽为60的屏幕上由上至下按字典序输出,要求每个字符串所占的宽度为所有字符串中最长的再加2,切行数最大。
注意:最后一行不用考虑额外加出的两个宽度。(用62去模)

解题思路:sort排序,再根据规律输出,格式控制借助了(printf("%-*s", int, char*).

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
using namespace std;

#define N 110
#define M 70

struct name{
char str[M];
};
int len;

int cmp(const name &a, const name &b)
{
if(strcmp(a.str, b.str) > 0)
return 0;
else
return 1;
}

int main()
{
int n;
int t;

while (cin >> n)
{
// Init.
len = 0;
name s
;

// Read.
for (int i = 0; i < n; ++i)
{
scanf("%s", s[i].str);
t = strlen(s[i].str);
if (len < t)
len = t;
}
len += 2;
// Count.
t = 62 / len;
int f = n / t;
if ( n % t)
f++;
sort(s,s + n,cmp);

printf("------------------------------------------------------------\n");
for (int i = 0; i < f; ++i)
{
for (int j = 0; j < t; ++j)
{
if (i + j * f < n)
printf("%-*s", len, s[i + j * f].str);
}
printf("\n");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: