您的位置:首页 > 其它

uva 644 Immediate Decodability(字符串处理)

2013-07-25 00:17 267 查看


 Immediate Decodability 
An encoding of a set of symbols is said to be immediately decodable if no code for one symbol is the prefix of a code for another symbol. We will assume for this problem that all codes are in binary, that no two codes within a set of codes are the
same, that each code has at least one bit and no more than ten bits, and that each set has at least two codes and no more than eight.

Examples: Assume an alphabet that has symbols {A, B, C, D}

The following code is immediately decodable:

A:01 B:10 C:0010 D:0000


but this one is not:

A:01 B:10 C:010 D:0000
 (Note that A is a prefix of C)


Input 

Write a program that accepts as input a series of groups of records from a data file. Each record in a group contains a collection of zeroes
and ones representing a binary code for a different symbol. Each group is followed by a single separator record containing a single 9; the separator records are not part of the group. Each group is independent of other groups; the codes in one group are not
related to codes in any other group (that is, each group is to be processed independently).


Output 

For each group, your program should determine whether the codes in that group are immediately decodable, and should print a single output line
giving the group number and stating whether the group is, or is not, immediately decodable.

The Sample Input describes the examples above.


Sample Input 

01
10
0010
0000
9
01
10
010
0000
9



Sample Output 

Set 1 is immediately decodable
Set 2 is not immediately decodable

题目大意:判断所给的字符串中有无前缀。
解题思路:将所给字符串用sort函数按长度排序,然后二重循环逐一判断。(注意长字符串不能做短字符串的前缀)

#include<iostream>
#include<string.h>
#include<algorithm>
using namespace std;

#define N 101
#define M 50

struct T{
char str[M];
};

int cmp(const T &a, const T &b)
{
return strlen(a.str) < strlen(b.str);
}

int main()
{
T tem
;
int cnt = 0;
int t = 1;
int bo = 0;
while(cin >> tem[cnt].str)
{
if (strcmp(tem[cnt++].str, "9"))
continue;

sort(tem, tem + cnt, cmp);

for (int i = 0; i < cnt; i++)
{
int k = strlen(tem[i].str);
for (int j = i + 1; j < cnt; j++)
{
if (strncmp(tem[i].str, tem[j].str, k) == 0)
{
bo = 1;
break;
}
}

if (bo)
break;
}

if (bo)
cout << "Set " << t++ << " is not immediately decodable" << endl;
else
cout << "Set " << t++ << " is immediately decodable" << endl;

// Init.
memset(tem, 0, sizeof(tem));
bo = 0;
cnt = 0;
}
return 0;}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: