您的位置:首页 > 其它

uva 10361 Automatic Poetry(字符串处理)

2013-07-24 23:35 351 查看
Automatic Poetry
Input: standard input
Output: standard output
Time Limit: 2 seconds
Memory Limit: 32 MB

 

“Oh God”, Lara Croft exclaims, “it’s one of these dumb riddles again!”
 
In Tomb Raider XIV, Lara is, as ever, gunning her way through ancient Egyptian pyramids, prehistoric caves and medival hallways. Now she is standing in front of some important Germanic looking doorway and has to solve a linguistic
riddle to pass. As usual, the riddle is not very intellectually challenging.
 
This time, the riddle involves poems containing a “Schuttelreim”. An example of a Schuttelreim is the following short poem:
 
Ein Kind halt seinen Schnabel nur,
wenn es hangt an der Nabelschnur.        
 
/*German contestants please forgive me. I had to modify something as they were not appearing correctly in plain text format*/
 
A Schuttelreim seems to be a typical German invention. The funny thing about this strange type of poetry is that if somebody gives you the first line and the beginning of the second one, you can complete the poem yourself. Well,
even a computer can do that, and your task is to write a program which completes them automatically. This will help Lara concentrate on the “action” part of Tomb Raider and not on the “intellectual” part.

Input

The input will begin with a line containing a single number n. After this line follow n pairs of lines containing Schuttelreims. The first line of each pair will be of the form
s1<s2>s3<s4>s5
 
where the si are possibly empty, strings of lowercase characters or blanks. The second line will be a string of lowercase characters or blanks ending with three dots “...”. Lines will we at most 100 characters long.

Output

For each pair of Schuttelreim lines l1 and l2 you are to output two lines c1 and c2 in the following way: c1 is the same as l1 only that the bracket marks “<”
and “>” are removed. Line c2 is the same as l2 , except that instead of the three dots the string s4s3s2s5 should appear.

Sample Input

3

ein kind haelt seinen <schn>abel <n>ur

wenn es haengt an der ...

weil wir zu spaet zur <>oma <k>amen

verpassten wir das ...

<d>u <b>ist

...

Sample Output

ein kind haelt seinen schnabel nur
wenn es haengt an der nabel schnur
weil wir zu spaet zur oma kamen
verpassten wir das koma amen
du bist
bu dist
题目大意:每组数据给出两组字符串,string1:s1<s2>s3<s4>s5的形式,转化后输出s1s2s3<s4s5.string2:s6...,其中"..."替换成s4s3s2s5.
解题思路:将s1~s6分别存储,再输出。

#include<iostream>
#include<string.h>
#include<stdio.h>
using namespace std;

#define N 105

int main(){

int n;
char str
, tem[5]
;
cin >> n;
getchar();

while (n--)
{
// Init.
memset(str, 0, sizeof(str));
memset(tem, 0, sizeof(tem));

// Read.
gets(str);

// Change.
int k = strlen(str);
int cnt = 0, t = 0;
for (int i = 0; i < k; i++)
{
if (str[i] == '<')
{
tem[cnt][t] = '\0';
t = 0;
cnt++;
}
else if (str[i] =='>')
{
tem[cnt][t] = '\0';
t = 0;
cnt++;
}
else
tem[cnt][t++] = str[i];
}

gets(str);

cout << tem[0] << tem[1] << tem[2] << tem[3] << tem[4] << endl;

for (int i = 0; str[i] != '\0'; i++)
if (str[i] =='.')
break;
else
putchar(str[i]);

cout << tem[3] << tem[2] << tem[1] << tem[4] << endl;

}
return 0;}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: