您的位置:首页 > 编程语言 > PHP开发

HDU 1094 A+B for Input-Output Practice (VI)

2013-07-07 17:13 232 查看

A+B for Input-Output Practice (VI)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 34187    Accepted Submission(s): 23106


[align=left]Problem Description[/align]
 

Your task is to calculate the sum of some integers.

 

 

[align=left]Input[/align]
 

Input contains multiple test cases, and one case one line. Each case starts with an integer N, and then N integers follow in the same line. 

 

 

[align=left]Output[/align]
 

For each test case you should output the sum of N integers in one line, and with one line of output for each line in input. 

 

 

[align=left]Sample Input[/align]
 

4 1 2 3 4
5 1 2 3 4 5

 

 

[align=left]Sample Output[/align]
 

10
15

 

水,代码如下:

 

 

#include<iostream>

using namespace std;

int main()

{

    int n;

    while(cin>>n)

    {

        int sum=0;

        while(n--)

        {

            int a;

            cin>>a;

            sum=sum+a;

        }

        cout<<sum<<endl;

    }

    return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: