您的位置:首页 > 理论基础 > 数据结构算法

数据结构基础+STL--tree recovery

2013-04-05 18:26 204 查看
Description
Little Valentineliked playing with binary trees very much. Her favorite game was constructingrandomly looking binary trees with capital letters in the nodes. 

This is an example of one of her creations: 

                                              D

                                             / \

                                            /   \

                                           B     E

                                          / \     \

                                         /   \     \

                                        A     C     G

                                                   /

                                                  /

                                                  F
 
To record her trees for future generations, she wrote down two strings for eachtree: a preorder traversal (root, left subtree, right subtree) and an inordertraversal (left subtree, root, right subtree). For the tree
drawn above the preordertraversal is DBACEGF and the inorder traversal is ABCDEFG. 

She thought that such a pair of strings would give enough information toreconstruct the tree later (but she never tried it). 

Now, years later, looking again at the strings, she realized thatreconstructing the trees was indeed possible, but only because she never hadused the same letter twice in the same tree. 

However, doing the reconstruction by hand, soon turned out to be tedious. 

So now she asks you to write a program that does the job for her! 
Input
The input will contain one or more testcases. 

Each test case consists of one line containing two strings preord and inord,representing the preorder traversal and inorder traversal of a binary tree.Both strings consist of unique capital letters. (Thus they are not longer than26 characters.) 

Input is terminated by end of file. 
Output
For each testcase, recover Valentine's binary tree and print one line containing the tree'spostorder traversal (left subtree, right subtree, root).
Sample Input
DBACEGF ABCDEFG
BCAD CBAD
Sample Output
ACBFGED
CDAB
利用前序序列和中序序列输出原树的后序序列

#include<stdio.h>

#include<string.h>

void build(int n,char*s1,char*s2)

{

   if(n<=0)

                   return;

   int p;

   p=strchr(s2,s1[0])-s2;

   build(p,s1+1,s2);//左子树

   build(n-p-1,s1+p+1,s2+p+1);//右子树

   printf("%c",s1[0]);

}

int main()

{

   char s1[30],s2[30];

   memset(s1,0,sizeof(s1));

   memset(s2,0,sizeof(s2));

   while(scanf("%s %s",s1,s2)!=EOF)

    {

       int n;

       n=strlen(s1);

       build(n,s1,s2);

       printf("\n");

    }

   return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: