您的位置:首页 > 编程语言 > PHP开发

HDOJ 【C】 1.1.4 A+B for Input-Output Practice (IV)

2013-01-10 12:40 519 查看

A+B for Input-Output Practice (IV)

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10400 Accepted Submission(s): 6104
Problem Description

Your task is to Calculate the sum of some integers.

Input

Input contains multiple test cases. Each test case contains a integer N, and then N integers follow in the same line. A test case starting with 0 terminates the input and this test case is not to be processed.

Output

For each group of input integers you should output their sum in one line, and with one line of output for each line in input.

Sample Input

4 1 2 3 4
5 1 2 3 4 5
0


Sample Output

10
15


Author

lcy

Recommend

JGShining

#include <stdio.h>

void main()
{
int n,i,sum,a;
scanf("%d",&n);
while(n!=0)
{   sum=0;
for(i=0; i<n; i++)
{
scanf("%d",&a);  /*  &不要忘了;a不可以用数组,因为不知道哦最大值*/
sum=sum+a;
}
printf("%d\n", sum);
scanf("%d",&n);
}

}



                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: